Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just moved into my apartment and the Internet connection is working. It's Comcast in case that matters. Anyway, I'm having trouble setting up my wireless router (Netgear WNR2000) to work with it. Are there any settings that I could be missing?

I currently have it set up to use a static IP address and I found the DNS servers I'm supposed to use and the Internet light is green, but I can't get out to the Internet. When I am trying, I'm connecting to an Ethernet port on the back of my router. Is there a setting I'm missing or a setting that I have set wrong? I used the automatic set up wizard to learn that it's a static IP address. Any help would be appreciated. I am currently only able to use my Linux machine, so please make any help in Linux commands.

Yes, I can connect to the Internet if I connect to the modem directly and I've been using the web interface when I'm connected to the router, so I suppose I can ping the router. My router detected the connection as using a static IP address, so I connected to the modem directly and figured out what my IP address, gateway, and mask were as well as DNS servers.

share|improve this question
1  
Is there any special reason to not to use DHCP? Isn't it compatible? –  Chathuranga Chandrasekara Aug 29 '09 at 14:42
    
To clarify, if you connect your computer directly to your modem, you can get to the internet, but if you connect your wireless router to your modem and your computer to your modem, you cant? Does your computer at least acknowledge the LAN connection? –  akf Aug 29 '09 at 14:50
    
Similar to akf: can you ping the router itself (e.g. "ping -t 192.168.1.1" from a console.) ? If this works, can you use the Web interface to the router? –  Peter Mortensen Aug 29 '09 at 16:21

3 Answers 3

up vote 2 down vote accepted

If you connect your PC directly to the modem and it works without you setting the IP address on your LAN card then you shouldn't be using static IP addresses. If you have an IP address manually set on your LAN card then it's not suprising that it won't work through your router, because you'll need to switch it to dynamic IP addresses once you're using your router.

I'd guess you should probably be using dynamic IP addresses in which case restart the modem after you've plugged in the router. Then try it, if it's not working restart the router as well.

share|improve this answer
    
I started with Dynamic IP address turned on and the internet light stayed amber. I didn't restart the modem though, so I'll try that later. –  indyK1ng Aug 29 '09 at 16:10

Are you sure it is a static IP address? You won't find that out from any wizard but by a notification from your service provider.

As for your DNS settings, you may alternatively use OpenDNS.

And I strongly recommend to contact your ISP's technical support and ask for help setting up your router, guesswork won't do you much good.

share|improve this answer
    
Before I set up the IP address as static, the router's internet light was amber, meaning it couldn't connect, now it's green, meaning it can. –  indyK1ng Aug 29 '09 at 15:09
    
well, were did you get the IP address from if not from your ISP? you can't just use any random WAN IP address. –  Molly7244 Aug 29 '09 at 15:29
    
and of course the light changes from amber to green the bery moment you enter any static IP address, but that doesn't necessarily mean that you are connected. same with windows IP settings, if you enter any IP the warning 'a network cable has been unplugged' will disappear but that doesn't mean you have a working connection. please do connect Comcast! –  Molly7244 Aug 29 '09 at 15:34
    
sorry for the typos, please do CONTACT Comcast. –  Molly7244 Aug 29 '09 at 15:36
    
I used ifconfig, which gave me the IP address and mask, route -n to get my gateway, and the resolv.conf file to get the DNS servers. Also, the internet is set up through my apartment, so I don't have comcast's number. I think I'll try Col's answer at some point in time. –  indyK1ng Aug 29 '09 at 16:08
  • Don't configure for static IP. I have Comcast and I have an external static IP but it was assigned by the cable modem. The router is configured to receive whatever is assigned by the cable modem.
  • You may need to have your router clone your computer's MAC address. The cable modem can be picky about which MAC address it sees.
  • As Col said, restart your cable modem (and router). My cable modem was a Motorola SBS-something and it needed a restart any time I changed the router's MAC address or it wouldn't connect to the internet.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.