Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hardware:

Motherboard: MSI BIG BANG Trinergy. According to specs supports up to 16Gb of RAM. CPU: Core i7 870 GPU: NVIDIA 460 GTX

and three 100% idential memory sticks 2Gb (1333+) each.

However Windows only sees 4Gb.

I have run CPU-Z tool and it shows all three sticks.

Every stick works individually.

share|improve this question
1  
    
Have you already run memtest to see if your hardware is ok? Burn knoppix to a disc and start your pc with this disc. Then choose Memory Test. What are the results? –  Martin Aug 8 '11 at 8:26
    
@Sathya all three thread not related to my case. Two of them are related to 945 chipset while I have P55 one. But thank you –  bakytn Aug 8 '11 at 8:36
    
@Martin all sticks work independently, but I will run MemTest for sure. –  bakytn Aug 8 '11 at 8:36
    
And you haven't mentioned if you use 32-bit or 64-bit Windows –  Sathya Aug 8 '11 at 8:41

3 Answers 3

up vote 3 down vote accepted

Intel Core i7 8xx supports only Dual Channel (two sticks). All three sticks would work with Core i7 9xx series.

Updating BIOS won't help, since motherboards support either Dual or Triple Channel. The best solution would be to buy an additional identical stick.

share|improve this answer
    
I bought additional stick (not 100% identical though) but now I have 8Gigs working. Thank you! –  bakytn Aug 9 '11 at 11:14
1  
Dual channel does not mean two sticks of memory. Dual channel means two interleaved channels. He's using single channel, which the Core i7 8xx most certainly fully supports. This is not the problem. –  David Schwartz Aug 29 '11 at 0:02

It may be that your motherboard is stuck in Dual Channel mode even though you have three stick installed (if you have an odd amount of ram installed and the motherboard supports it it should go back to single channel mode).

Have a look in your BIOS and see if you can force it into single channel mode or get a matching RAM module to pair with your third memory stick.

share|improve this answer
    
In BIOS I couldn't find a way to change it. I will try to upgrade the BIOS firmware. By the way, CPU-Z is showing: Single in "Channels #" field. I think all is from the buggy firmware probably. Will get to back after upgrading it. –  bakytn Aug 8 '11 at 8:49
1  
No, this is correct. Because you don't have the same amount of memory on each channel, you cannot run in dual-channel mode. You are running in single-channel mode. –  David Schwartz Aug 29 '11 at 0:02

Dual-channel mode has to do with how the channels are used, it has nothing to do with the amount of memory that's visible. Yes, you're in single-channel mode (because the channels aren't balanced), but that's not why the system can't use your memory.

The system can't use your memory, most likely, because memory remapping isn't enabled in your BIOS.

share|improve this answer
    
How it looks like in BIOS then? because I gone through all available options. –  bakytn Aug 28 '11 at 23:07
    
The option is usually called memory remapping and you need to turn it on for a 64-bit operating system. –  David Schwartz Aug 29 '11 at 0:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.