Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Apologies if this is not the appropriate section for this question...

I'm a newbie as far as dealing with networking issues. Until last week, I had no problem using ssh to connect to my work Mac from my laptop Mac. Then I installed an OS update (to OS X 10.6.8). Now, when I try to ssh, I get "timeout" errors.

I am pretty sure this is not a firewall problem. In my System Preferences, I have set my firewall to allow incoming ssh connections.

I did:

ssh -v me@whereIam.m[email protected]

and got:

    OpenSSH_5.2p1, OpenSSL 0.9.8r 8 Feb 2011
    debug1: Reading configuration data /etc/ssh_config
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to whereIam.myWork.myCountry [123.456.789.10] port 22.
    ssh: connect to host whereIam.myWork.myCountry port 22: Operation timed out

which makes no sense to me at all! If anyone could suggest what the problem might be, I would be extremely grateful. I miss working from my sofa.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

1) Did you update both machines or just one? If so which one?

2) If you take your laptop to the office, can you ssh to the machine there?

3) Are you connecting via VPN? If so, can you access other office resources without issue?

share|improve this answer
    
Thanks for your help. 1) Both. 2) I have tried that and I can't. I'm sitting right next to my Desktop computer right now with my laptop; I'm on the same network. Still doesn't work. 3) I can access other office resources. I did try connecting via VPN from home (puts me on work network) and that didn't help. –  Ant Aug 8 '11 at 17:17
    
P.S. The reason I think the update was the cause--aside from the timing--is that I first updated the laptop, then started having ssh problems. I couldn't connect, but the connection would come right after an hour or two. I THEN updated the OS on the work Desktop MacPro and since then ssh has not worked at all. But I can still ssh into a colleagues Linux. –  Ant Aug 8 '11 at 17:20
    
codeps -aef | grep ssh code on the machine you're trying to connect to. If the ssh daemon is not running re-enable it. You're only using password and not ssh keys? –  user90276 Aug 8 '11 at 20:16
    
Thanks... I'll try that. But what is an ssh key? –  Ant Aug 8 '11 at 20:22
    
Well, I may not have understood correctly... I did: codeps -aef | grep ssh code. I got: grep: code: No such file or directory, -bash: codeps: command not found –  Ant Aug 8 '11 at 20:30
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.