Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just installed Windows 7, with the user name USERNAME, and machine name MACHINENAME. The home path is set to C:\Users\USERNAME.MACHINENAME. (The computer is NOT on a domain.)

How do I change it to just C:\Users\USERNAME?

share|improve this question
    
Delete the account and recreate it? –  user3463 Aug 8 '11 at 19:52
    
Then how do I prevent the same thing happening again? –  Peter Aug 8 '11 at 20:02
1  
Out of interest, what is the name of the account? Normally you'd only see that behavior when creating an account with a name that already exists. –  Windos Aug 8 '11 at 20:20
    
There is only one user account: USERNAME. However there are two folders in C:\Users: USERNAME and USERNAME.MACHINENAME. The USERNAME account points to the USERNAME.MACHINENAME folder. Not sure how this came about, it was unintentional. –  Peter Aug 8 '11 at 20:29
    
Also, I've installed a bunch of s/w already, so I'm hoping I can do this without deleting the account. –  Peter Aug 8 '11 at 20:34

2 Answers 2

Like @Randolph said, delete the account. This would be the most sure fire fix. Here is the process I would follow:

n.b. You may need to activate and log into your local administrator account to do this.

  1. Open the Advanced System Properties (Open the Start Menu, Right-Click Computer and choose Properties, then click the Advanced system settings link.)
  2. Click Settings... in the User Profiles area, then delete the profile.
  3. List item Computer Management Console. (Open the Start Menu, Right-Click Computer and choose Manage)
  4. Double-Click "Local Users and Groups", then "Users." If you account is still listed, delete it.
  5. Open the registry editor. Win+r and type regedit and hit enter.
  6. Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\ProfileList. There shouldn't be any reminants of the profile left now, but if you notice an entry for it in the profile list, delete it.
  7. Finally, navigate to C:\Users and make sure those two folders and both gone.

Restart for good measure, then create the account again.


If you REALLY want to hack at it you can try this (I don't guarantee that this will defiantly work):

  1. Open the Local Users and Groups area of the Management Console as described above.
  2. Double click the account and go to the Profile tab.
  3. Enter the profile path and home folder (local path) as "C:\Users\USERNAME\"
  4. Copy the contents of "C:\Users\USERNAME.COMPUTERNAME\" and delete "C:\Users\USERNAME\"
  5. Recreate the folder "C:\Users\USERNAME\" and paste the contents of "C:\Users\USERNAME.COMPUTERNAME\" into it.
  6. Delete "C:\Users\USERNAME.COMPUTERNAME\"
  7. Restart and pray.
share|improve this answer

I see this all the time when people join their PCs to a domain, or join them off a domain. I'll also see this on upgraded installations.

If you REALLY want to hack at it you can try this (I don't guarantee that this will defiantly work):

Open the Local Users and Groups area of the Management Console as described above. Double click the account and go to the Profile tab. Enter the profile path and home folder (local path) as "C:\Users\USERNAME\" Copy the contents of "C:\Users\USERNAME.COMPUTERNAME\" and delete "C:\Users\USERNAME\" Recreate the folder "C:\Users\USERNAME\" and paste the contents of "C:\Users\USERNAME.COMPUTERNAME\" >into it. Delete "C:\Users\USERNAME.COMPUTERNAME\" Restart and pray.

Pray?

Sigh. Microsoft takes all that time to create a tool called Windows Easy Transfer, which has existed since XP, but people, for some reason, choose to do things the hard way. De-evolution ftl.

and if you don't have it, http://windows.microsoft.com/en-US/windows7/products/features/windows-easy-transfer

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.