Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Chrome in Vista 64 and it crashes a LOT (sometimes every time I change pages). I find it happens on almost any site, but is more common when the site has flash, and also more common when I also have FireFox running. Any ideas?

share|improve this question

4 Answers 4

up vote 4 down vote accepted

Well... sounds like Flash is the culprit, eh?

Make sure you have the latest-greatest version of Flash installed. And if that doesn't work, modify your shortcut to pass the -disable-plugins parameter to chrome.exe (and then close all Chrome windows and re-open) - this will disable Flash completely (as well as any other plugins you might have).

share|improve this answer
    
Thanks for this. I updated my Flash and that "seems?" to have fixed my multi-crash problem. Regards. –  Xavierjazz Feb 26 '10 at 18:39

Flash has been implicated in all the stability issues I've had with Chrome (on XP), so I believe you're on to something there. All I can really recommend, though, is making sure you have the latest, greatest versions of everything, and if that doesn't help, staying away from Flash. Sorry. :(

Oh, actually, there is one thing. If you're using Incognito mode, you might want to try without. Sometimes it's seemed as if Flash is unhappy with it, possibly as if it causes Flash to blow out Chrome's memory usage (which might relate to the having Firefox open part of things).

share|improve this answer

Do you get an error message? Microsoft .NET Framework may have something to do with it; but that usually gives an error message something like (or exactly like):

The application failed to initialize properly (0xc0000135). Click OK to terminate the application.

What more can you tell us about your problem?

share|improve this answer

Chrome Browser crashes with Windows Vista (only during initial launch):

we have to disable superfetch service from Vista services:

  • Start -> Run -> Services.msc

  • scroll down to locate Superfetch service

  • double-click mouse on Superfetch

  • choose Startup-type to Disbled.

  • click Apply

  • Reboot the system

It is good to delete all the files from C:\Windows\Prefetch folder regularly. We can delete the Prefetch folder itself completely, after deleting the Prefetch\Readyboot folder.

share|improve this answer
    
Using Capital Alphabets won't add any difference to your answer. –  Pankaj Oct 29 at 7:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.