Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My onboard Realtek RTL8168B/8111B Family Gigabit Ethernet is losing packets (about 8% when pinging any other device on the LAN).

There are no events in the Windows event logs relating to TCPIP/ICMP or frame errors. i used the Windows Performance Monitor tool to watch the events under "Network Interface" category, hoping to see some symptom of the packet loss. i could not find any

Can anyone think of any way to "see" the packet loss as a diagnostic condition, rather than doing pings and watching responses not come back? If i can find anyplace in Windows where the packet loss comes back to something else (crc error, checksum error, fragmentation problem, etc) maybe i can diagnose it.


It's a new machine, and i assume the problem is with some of the configuration options in the driver:

  • Speed & Duplex: Auto Negotiation
  • Flow Control: Disabled
  • Receive Buffers: 512
  • Transmit Buffers: 128

  • Interrupt Moderation: Enabled

  • Receive Side Scaling: Enabled
  • Priority & VLAN Enabled: Priority & VLAN Enabled

  • Auto Disable Gigabit (PowerSaving): Disabled

  • Auto Disable PCIe (PowerSaving): Disabled
  • Auto Disable PHY (PowerSaving): Disabled
  • Green Ethernet: Disabled

  • Shutdown Wake-On-Lan: Enabled

  • Sleep WOL Power Saving: Disabled

  • IPv4 Checksum Offload: Rx & Tx Enabled

  • TCP Checksum Offload (IPv): Rx & Tx Enabled
  • TCP Checksum Offload (IPv6): Rx & Tx Enabled
  • UDP Checksum Offload (IPv): Rx & Tx Enabled
  • UDP Checksum Offload (IPv6): Rx & Tx Enabled
  • Jumbo Frame: Disabled
  • Large Send Offload (IPv4): Enabled
  • Large Send Offload v2 (IPv4): Disabled
  • Large Send Offload v2 (IPv6): Enabled


i tried forcing Speed & Duplex to 100 Mbps Full Duplex (which is what it is anyway) without success.

share|improve this question

3 Answers 3

Use Wireshark to see what packages are lost/malformed. Unfortunately, it is an issue depending on drivers as well.

share|improve this answer
    
At first i thought that sounded like a good idea. But the more i thought about it the more i realized it would just help confirm that i'm randomly losing packets. –  Ian Boyd Nov 3 '09 at 15:35

Have you tried a ping from some other machine to this interface?
Do you get any ICMP errors?

It would also be useful checking the interface statistics of the peer-device to which the interface is wired.

  1. what is the network device you connect to?
  2. Does it have any interface statistics?
  3. Do they show any specific errors that other interfaces of that device do not show?

Finally, it could also be a loose wire on the path.
If you have more than two machines on your network,
is this particular machine connected in some different way? (Wireless hop?)
Have you checked that the connectors are firmly wired?

If you see loss with just regular ping packets (64 byte), IP Fragmentation is ruled out.
If your interfaces show no error counts, CRC errors are also ruled out.

share|improve this answer

enable the FLOW CONTROl setting. try it out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.