Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a machine running Windows XP SP3 using IE7. When I go to ups.com, choose USA, and click the login button at the top of the page, the page hangs and never loads.

If I change the DNS to google's 8.8.8.8 the page loads.

All of the other machines (there are more than ten of them) using the same DNS that this computer used before switching to google are able to load the page just fine.

This makes me believe it's an issue with this computer and not DNS.

I checked this on machines running IE7 and IE8 and they were able to load the login page.

What is causing this problem?


Update: This began happening on more than one computer.

share|improve this question
add comment

2 Answers

Try flushing your local DNS cache:

  1. Change your DNS back from google to whatever it was

  2. Go to Start->Run or hit Windows Key+R

  3. Type: "cmd" (no quotes) and hit Enter

  4. In the command prompt, type: "ipconfig /flushdns" (no quotes) and hit Enter

  5. Try going to the site again.

If that doesn't work, there's a few more things you can do:

  • Make sure that you have the latest updates in IE
  • See if you can view the page in another browser
  • See if disabling anti-virus or firewall does anything
  • See if the page is actually loading something while it's "hanging" (i.e. look at the status bar to see if it's doing anything)
share|improve this answer
    
Flushdns had no effect. I'll get back to you regarding the next steps. –  Tyler Faile Aug 9 '11 at 19:39
    
Can't view the page in another browser, disabling firewall does nothing. I believe this has to do with our proxy server. –  Tyler Faile Aug 10 '11 at 21:49
    
Are the other computers on the proxy? Does the proxy have some kind of DNS override or IP filter that would be preventing the site from loading? What about my fourth extra point above? –  Richard Marskell - Drackir Aug 11 '11 at 0:34
add comment
up vote 0 down vote accepted

Okay, I finally got this resolved. It wasn't a problem with the DNS server as I originally suspected. The issue was that Path MTU Discovery is disabled on our server as a reaction to several denial of service attacks.

Setting the MTU lower on our client machines fixes this issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.