Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having an interesting issue that is displayed below. Essentially I have a bootcamp partition of Windows7 loaded in OSX Lion via VMWare Fusion and everything seems to work swimmingly with the exception of Visual Studio 2010.

Visual Studio 2010 appears to have an odd red overlay all over it (including menus). This behavior only occurs when running in VMWare Fusion, if I reboot into Windows7 via bootcamp then everything is spectacular.

I have not noticed rendering issues with any other application while running in the virtualization layer and also this happens whether it is windowed, unit or full screen.

I installed the theme switcher extension for VS2010 thinking maybe through the virtualization some of the default colors were being translated incorrectly but every theme has the same exact effect, with the exception of being different shades of red.

Again, all other applications run perfectly with no flaw in appearance, but the only application I really care about is visual studio and I simply cannot code like this!

Has anyone else run into any issue similar to this?

VMWare is set to offer full 3D support for display on the VM (I cannot change this setting) and in Windows7 itself the display adapter is set to 32bit color.

I have rebooted both OS' and still the issue persists so I am pretty open to any suggestions.

Red Visual Studio 2010 in OSX Lion via VMWare Fusion

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You don't happen to have the WPF performance tools running?

share|improve this answer
    
I also was guessing that it has something to do with the WPF layer that most of the editor was created in. If you notice, the solution explorer which is still written in C++ doesn't have that color overlay on it. –  Chris Aug 9 '11 at 19:30
    
I have never specifically installed any WPF performance tools although the version of VS is ultimate, could it be something pre-installed that is causing the issue?.. I am going to make a quick WPF app to see if it is also affected. –  Quintin Robinson Aug 9 '11 at 19:39
    
No, you have to specifically turn it on. My other suggestion is to turn off or on the "automatically use hardware acceleration" in VS. If it is off, turn it on. Off, turn it on and see. Also, try a different theme. I think this is specific to VS, since Windows 7 DVM uses much of the same kernel components as WPF, but your taskbar isn't red. –  surfasb Aug 9 '11 at 19:43
    
I just made a little WPF app to test out the theory and indeed it is also under the red-effect. I am going to play with the drivers and see if I can find a working combo for the display. Do you have any other suggestions? –  Quintin Robinson Aug 9 '11 at 19:47
    
@surfasb Superb; about 8+ years in different visual studio versions and I had no idea there was even an option for hardware acceleration, it is now disabled and works like a champ, thanks again! I don't know what to do of any other WPF apps but my interaction with them is generally limited so I am not that worried. –  Quintin Robinson Aug 9 '11 at 19:51

WPF hardware acceleration can be disabled by setting a registry value:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration

It's a DWORD value; set it to 1 to disable acceleration. This has at least partially fixed the issue for me with Autodesk Revit under VMWare Fusion.

Link:

http://msdn.microsoft.com/en-us/library/aa970912.aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.