Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got a 3TB external drive. When I first plugged it in, it showed up as a 2.7TB drive (as expected). Whenever I get a new external device I like to format it (and admittedly, I succeeded initially with the simple right click format from My Computer) but I wanted to try something different. So I went into Computer Management and deleted the partition on the hard drive and the following came up:

Computer Management 1

So that's strange. What started as a single partition now became two blocks of unallocated space. I can only partitions in the first block:

Computer Management 2

I am also not able to extend the first partition. I created the partition as large as Windows would allow me.

How can I join these two unallocated spaces back together again?

I am using Windows 7 Professional, if that means anything special.

share|improve this question
    
+1 cause I like screenshots. –  Doc Aug 9 '11 at 22:20

2 Answers 2

up vote 1 down vote accepted

What you need to do is format the drive as a GPT partition. What is happening is that you are being limited by the specifications of MBR. MBR < 2tb. Once you change the partitioning of the device you will be able to have one large drive. Get there by right clicking on the Disk 2 and change it from there. That way you don't need any third-party software.

share|improve this answer
    
Already used GParted but this will be good to know in the future. Thanks. I've changed the accepted answer (sorry, Doc, this guy needs some more reputation anyway). –  KPthunder Aug 11 '11 at 3:29

Can you not click on where it says "Disk 2" and do some kind of reinitialization there?

If not, a quickish solution I'd use is just burn GParted to a CD and use it to fix up your partitioning accordingly.

share|improve this answer
    
No relevant options are available in that context menu. I'm thinking I did something that Windows can't see for some reason and therefore I will have to go with GParted. –  KPthunder Aug 9 '11 at 22:22
    
KPthunder: If I knew a quick Windowsy solution, that'd probably end up being faster. But I never really learn such solutions for stuff like this cause I always end up finding a fast linuxy solution. GParted is AWESOME. –  Doc Aug 9 '11 at 22:28
    
Yes, I like GParted as well. I just don't like shutting off my computer to use it. I'm about to go ahead and use GParted. If it's able to fix the disk I'll accept your answer. –  KPthunder Aug 9 '11 at 22:35
    
It'll work, it's GParted!?!! Indeed rebooting is lame, but that's what you get for running Windows ;) –  Doc Aug 9 '11 at 22:50
    
Well, it took a while (freaking graphics settings, man...) but it worked. I wonder what happened in the first place... When I started up Windows again it said that one of my USB devices had malfunctioned and wasn't recognized... but the drive appears to be working fine... –  KPthunder Aug 9 '11 at 23:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.