Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not entirely sure how but my Windows 7 is not starting properly and after running the automatic repair program multiple times and still not fixing I gave up. (I am using a Laptop)

My option now is to install Windows 7 again from the partition that is provided by the manufacturer.

I have 2 questions:

  1. If I install from that partition will it REMOVE all of my existing files?
  2. Assuming that my old data would be removed I took the Hard Drive out connected it to an external enclosure and started copying the Hard Disk to another computer. The problem I am running into are the files that are saved under users that have/had passwords on their computer (Even though this is a home computer their were 3 users). It gives me a pop-up saying the Administrative password is required (I have that), but then just cannot open the folder, and if I just copy only some files / folders are copied but not all.
share|improve this question
    
Using your OEM tools, it may remove the files; using any original installation media (i.e. the original/MSDN Windows 7 disc/ISO), you can simply overwrite just the Windows install so you can recover your files. Assuming you have a legit serial number (should be on the bottom of your laptop, as well as the appropriate Windows edition), you can legally obtain a Windows ISO from the usual places, or the MSDN if you have an account. From there, re-install it over your system using your serial number, recover your files to another partition/drive, and then re-format the drive. –  Breakthrough Aug 10 '11 at 16:05
    
Post your Make and Model for more specific details on how to use the recovery partition. –  Moab Aug 10 '11 at 16:16
1  
@Moab I know how to use the recovery partition. I don't need help with that. I just need to know the effects of it. Does all data get erased? –  Pranav Shah Aug 10 '11 at 19:32
    
@Breakthrough I do have the sticker, but the key is not readable. I called the manufacturer (Asus) and asked if they could give me the key based on Serial Number, but they were unable to do so. –  Pranav Shah Aug 10 '11 at 19:34
    
@Pranav, almost all recovery partition solutions wipe all partitions and start from scratch to rebuild the PC, when in doubt always back up your data. –  Moab Aug 10 '11 at 20:15
add comment

3 Answers 3

You could try taking ownership of the files. Right click on the drive in the arrangement where it is asking you for a password to access the files. Select Properties, then Security. First make sure Administrator has full control and then select Advanced. In the Ownership tab, set ownership of the files to Administrator and apply to sub folders and files.

See if you can access the files now.

share|improve this answer
    
I will give that a try and let you know. Thanks for the suggestion –  Pranav Shah Aug 10 '11 at 19:35
    
I think it worked, but I am having some folder related issues I will mark the answer as a solution once I solve the other problem. –  Pranav Shah Aug 12 '11 at 2:37
    
What sorts of other issues? –  music2myear Aug 12 '11 at 14:18
    
Accessing the data is really slow. Even if I click on a folder it takes a long time for it to open. I created another question regarding this. –  Pranav Shah Aug 12 '11 at 14:54
add comment

You can ask the Windows installer to install to the existing file system, leaving the files intact. It will delete operating system files, but other files should usually be fine, tho not always.

If you really want to be sure, start by connecting external hard drive, boot OS from Live CD and copy the whole partition to the external drive. The best tool for this is Live CD from Debian/Ubuntu, one without graphical user interface, but if you don't know how to use Linux, you can try to get Windows Live CD.

Other options are to detach the hard drive and attach it to some other desktop machine and copy files that way. Or to get SATA-to-USB adapter, or external USB enclosure, and connect the hard drive with it to some other computer.

If you can't use Unix and Windows refuses to copy the data, you can try to gain ownership of the files and then change permissions. This explains one way to do it: http://www.addictivetips.com/windows-tips/windows-7-access-denied-permission-ownership/

share|improve this answer
    
I think he only has the recovery tools from the OEM, so it would not provide this option. –  Breakthrough Aug 10 '11 at 16:02
    
The live CDs I was talking about are freely downloadable from the Internet, at least the Debian and Ubuntu ones, which are open source. They are very handy for emergency repairs, also because you can bypass Windows security management with them. Within Windows it's very hard to grab whole filesystem without missing any hidden/protected/whatnot files. –  Zds Aug 10 '11 at 18:43
    
I wasn't talking about a live CD, I was talking about your first sentence (referencing the Windows installer). From the OP's question, "My option now is to install Windows 7 again from the partition that is provided by the manufacturer." Very rarely do these tools provide you with the same install options as the Windows installation disc itself (thus my comment under the main question), they usually don't even show you the Windows installer itself (most use OEM-based GUIs which perform an unattended install in the background). –  Breakthrough Aug 10 '11 at 18:45
1  
@Zds I am already trying the SATA-to-USB approach, but am unable to copy all files, due to file/folder being possibly locked by the OS. I need to just figure out to provide a ADMIN password or something so that all files are accessible. –  Pranav Shah Aug 10 '11 at 19:38
1  
@Pranav: For that Debian live CD without GUI works very well, as it can bypass those.. but you need someone who is able to use Unix for that to be useful. –  Zds Aug 11 '11 at 7:45
add comment

You can also use a laptop hard drive enclosure. Take out your laptop hard drive, put it in the enclosure and you can use it as an external hard drive. Plug it into another machine and copy all your files.

share|improve this answer
    
The copy all file option is not working. I am unable to copy some files and that is one of the questions I asked. Please read question 2 for complete details. –  Pranav Shah Aug 10 '11 at 19:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.