Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can define new abbreviations no problem: e.g.

:ab Lunix Linux

defines an "Lunix" as an abbreviation for "Linux", as confirmed by the list which appears when I execute :ab.

In a plain text file, such as an empty buffer, this expands correctly, but with some filetypes neither SPACE nor CTRL-] seem to work.

Is there a setting or mapping which might be getting messed up by some of my filetype plugins?

There's probably a really obvious answer to this, but I haven't found it hunting through the :help documentation yet.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Could you have installed LaTeX-Suite/the IMAP plugin? It may interfere with mappings and abbreviations.

You may also want to check whether any of the four timeout related settings have been changed.

share|improve this answer
    
Yes, turns out IMAP was getting in the way even in non-LaTeX files. I'll have to duplicate any abbreviations I want to use with IMAP() calls as well. –  Jez Aug 12 '11 at 9:26
    
Not necessary duplicate. If IMAP is always active, you can just write your abbreviations to use IMAP. If not, the easier way would be to write a command that tests exist('*IMAP') to uses either iabbr or IMAP(). –  Luc Hermitte Aug 12 '11 at 11:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.