Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

my configuration is as follows: Internet connection coming from the office (don't know details) => D-Link DIR-632 => Desktop Computer (Win 7), printer, Vonage.

I have Microsoft Lync and Outlook 2010. Both keep dropping on and off. For Lync it disconnects and then reconnects every 5 minutes or so. Outlook sends and receives fine at first and then eventually it stops receiving mail. I use it with an Exchange Server (Office 365), Hotmail (Outlook Connector), and IMAP (gmail). If I then restart Outlook mail starts coming in and eventually stops again.

The router is not restarting because I can still browse the web and Windows doesn't notify me of a failed network connection.

If I remove the router out of the equation (plugin in the internet directly to the desktop), this behavior doesn't occur.

My question is, is this a bad router or do I need to configure something?

share|improve this question
    
I don't know that particular router, but I've had pretty horrible luck with D-Link routers in the past. – Doc Aug 10 '11 at 15:40
    
Chances are this is a firewall issue or a problem with NAT traversal. Look for active firewalling settings like ALG, SPI or intrusion detection. Make sure that all ports that these applications use are open/forwarded correctly. – MaQleod Aug 10 '11 at 16:22
    
In reference to my last comment: files.dlink.com.au/Products/DIR-632/Manuals/… - page 33 for port forwarding, 34 for application rules (may work better than port forwarding), page 42 for firewall settings (antispoof may be bad, DMZ may help). – MaQleod Aug 10 '11 at 16:39
    
@MaQleod Can you be more specific on what you mean by make sure these ports are...open/forwarded correctly? What setting for open/forward consitutes correctly for this issue? – SAFX Apr 11 '13 at 16:18
1  
@SAFX, some applications or devices use multiple ports, it may be that only part of the range was forwarded so that certain signals in order to keep a session alive were not making it through and therefore cutting off the session. I have see this happen frequently with SIP devices. – MaQleod Apr 11 '13 at 22:52
up vote 4 down vote accepted

Based on MaQleod comments above, I logged in to the Router's admin site, went to Advanced - Firewall Settings and changed Enable SPI => Unchecked UDP Endpoint Filtering => Endpoint Independent TCP Endpoint Filtering => Endpoint Independent

The problem hasn't happened since...

UPDATE: I have since changed the firmware of the router to use dd-wrt. I finally have an awesome router with 8 LAN ports that works as expected! Love dd-wrt.

share|improve this answer
    
i went over your settings and i still have lync problems, is there something i'm missing? superuser.com/questions/831385/… – killerbarney Oct 25 '14 at 20:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .