Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I took my computer with me while house sitting. Now back at home, DHCP is setting an IP on the router, but I get a 169.x.x.x IP on the computer.

I've tried using a static IP but was unable to connect to the router. I've also tried different cables and ports on the router, but with no effect. Is there anything else I can try? I'm guessing the onboard NIC is not working.

share|improve this question
Please provide details about the environment (windows, mac, linux) and if you can an ipconfig/ifconfig readout of the adapter you are using. Even better would be a readout of tcpdump -i interface port 67 when you connect the computer to the router (this will give the handoff between the computer and the router for DHCP to see what is happening) - if you are on windows, you can get it here: – MaQleod Aug 10 '11 at 17:49
Sorry it's a windows 7 64bit box, I'm not at home so I can't give any readouts at the moment. – Michael Aug 10 '11 at 18:31

As you said, I would guess this is a problem with the NIC on your computer.

I have had many computers just randomly fail and not being able to connect for random unknown reasons.

What fixes it 75% of the time for me is going in to device manager and uninstalling the device/choosing remove. I then scan for new hardware and let it reinstall, and it appears to work fine.

All I can guess is it fails due to corrupt settings stored in the registry or elsewhere.

The other 25% of the time, I was never able to fix it and I had to add a PCI NIC :(

I hope this helps you!

share|improve this answer
That worked perfectly, thanks! – Michael Aug 13 '11 at 14:13
Apparently not, shut down the comp and now it's not working anymore. – Michael Aug 13 '11 at 18:55
@Michael, All I can say is to try the same steps again. – William Hilsum Aug 13 '11 at 19:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.