Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I did a fresh install of WAMP (v2.1) and it works excep the MySQL isn't starting.... here:

enter image description here

and everytime I press "Start/Resume Service", NOTHING happens.

I go to my.ini and put in a password.Then go to MySQL console.. type in that password and either 1. the console dissapeares or 2. I get Error 2003 "Can't connect to MySQL server on 'localhost' (10061)"

share|improve this question

migrated from stackoverflow.com Aug 11 '11 at 7:22

This question came from our site for professional and enthusiast programmers.

1  
did you mistype here or in your config? should be "localhost" not "localhodst" –  Endophage Aug 11 '11 at 4:49
    
whoops typo on my part. yeah it's localhost... but i did not mistype in the mysql thingy.... it is localhost... still same error –  naknode Aug 11 '11 at 4:58
    
when i type netstat on cmd... i do not see port 3306 being used... even though it's allowed in my windows firewall.. i am using vista... 64-bit –  naknode Aug 11 '11 at 4:59
    
What happens when you try to run mysqld directly? –  Dan Grossman Aug 11 '11 at 5:34
    
How do I run mysqld? –  naknode Aug 11 '11 at 6:08

2 Answers 2

up vote 2 down vote accepted

Error No. 2003: Can't connect to MySQL server on 'localhost' (or some other host)

simply means that connection is not possible for one of the following (or similar) reasons:

  • There is no MySQL server running at the specified host

  • Connection to the MySQL server is not allowed using TCP-IP. Check the 'skip-networking' setting in the MySQL configuration file (my.ini on Windows, my.cnf on Unix/Linux). It shall be commented out like '#skip-networking'. If it is not commented out, then do it and restart the MySQL server for the change to take effect.

  • Some networking issue prevents connection. It could be a network malconfiguration or a firewall issue. You need to allow the service mysql on windows firewall/ after you install wamp, restart ur pc. and start wamp

windows will ask is msqlnt.exe allowed to run and accept it then its fine.

If it doesn't work then:

Try turning off the windows firewall - if that fixes the problem, then turn it back on, and allow access to TCP/3306(default port)

  • When trying to connect to a MySQL server at an ISP this error message often indicates that direct connection to MySQL has been blocked. You must then use HTTP-tunneling or SSH-tunneling to connect.
share|improve this answer

Search for mysql-bin.index file, delete it, then restart MySQL.
This worked for me ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.