Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday Notepad++ was runnable, but today it doesn't. In spite of the notepad++.exe (with its 13 process) presence is the tasks manager, Notepad++ window doesn't launch.

I tried to uninstall and re-install the sofware (and the first launch works), notepad.exe is present in C:\Windows and C:\Windows\Sytem32 folders.

The last file opened with notepad++ was a xml file which isn't readable by other softwares because of the following error message :

The '<' caracter can not be used in a value attribut

What can I do please ?

share|improve this question

migrated from stackoverflow.com Aug 11 '11 at 9:04

This question came from our site for professional and enthusiast programmers.

1  
"notepad.exe is present in..." What does this have to do with Windows Notepad? Make sure never to touch that. It's a system application. – BoltClock Aug 11 '11 at 8:52
    
Do you configure Notepad++ to remember the files you had open before closing it? Is that XML file one of those files? – BoltClock Aug 11 '11 at 8:54
    
On the internet the first response to this problem is to check the process software presence on the taks manager, that's why I specifies. And it's my own XML file – Dsandre Aug 11 '11 at 9:01
    
Does it appear in the taskbar? If so, the program may be displaying itself off-screen. In that case, immediately after starting, press Alt-Spacebar followed by X which should show it maximised. (Or Alt-SpaceBar, follwed by M (for Move) and then use the arrows keys to move the windows around. (Of course, you don't know which direction you have to move it or how far). – sgmoore Aug 11 '11 at 9:46
    
@sgmoore : No it doesn't. Notepad++ window isn't present in the taskbar, only in the task manager. I'm using a double screen – Dsandre Aug 11 '11 at 10:01

Try removing the file from C:\Users\<username>\AppData\Roaming\Notepad++\session.xml which reopens the file when you start the program.

If that does not work, maybe you should try a complete uninstall/reinstall if you haven't already.

EDIT: Workaround found (thanks to sgmoore): Install standalone version of Notepad++ (notepad++ portable).

share|improve this answer
    
thank you for tracking ;) But I tried this solution thank's to "Revo-Uninstaller" to do a full re-installation of notepad++. All temp/conf files have been remove after the second/third installation – Dsandre Aug 11 '11 at 9:44
1  
If you try the uninstall make sure, make sure you remove all the files it leaves behind too. Just in case. – Windos Aug 11 '11 at 9:44
    
the username should go in the path as well. had written it between tags, so it was removed :P C:\Users\YOUR_USERNAME\AppData\Roaming\Notepad++\session.xml – Allman Aug 11 '11 at 9:45
    
@Window, how can I be sure that all files have been remove ? I use Revo to precisely remove all files I can't find by myself. – Dsandre Aug 11 '11 at 9:47
1  
You could try running a portable version of NotePad++ (see portableapps.com/apps/development/notepadpp_portable ) which should not use any of the settings from the previous install. – sgmoore Aug 11 '11 at 10:04

I encountered the same problem as you. Do the following:

  • Go to C:\Program Files\Notepad++\plugins
  • Move LightExplorer.dll to C:\Program Files\Notepad++\plugins\disabled.

If you cannot find LightExplorer.dll then move Explorer.dll to C:\Program Files\Notepad++\plugins\disabled

The problem should be solved with this method.

share|improve this answer
    
the mystery is all, since this problem I used the portable version of NotePad++. In order to test your solution I reinstalled the standard version of Notepad++ , gold today it works. it is not understandable. The computer in which I met this problem is professional, someone could corrected this worries in my absence. Thank's you – Dsandre Sep 15 '11 at 8:00
1  
+1 - 3 years later and this solution was the only one that worked for me. Thanks. – ThinkingMedia Oct 30 '14 at 13:30

I sometimes get this problem too, all I do is:

  1. use task manager to kill those np++ processes
  2. Find np++ shortcut in the start menu, right click and chose "Run as Administrator" (window appeared)
  3. Close this np++ window, then reopen it normally (without Administrator) and it works.

I assume it is something like the session file, or a plugin, that gets locked up, or refuses access, and running as administrator clears that issue - but I could be wrong.

Hope my solution works for you, and anyone else who experiences this issue.

share|improve this answer
    
Thanks @Glenlku, I tried Allman's suggestion (which had worked for me in the past), but it didn't do it. I tried your's after removing the session.xml and it allowed np++ to start. – Michael La Voie Feb 12 '13 at 1:56
    
This worked for me and after running as administrator, I also got a "Windows Security" login prompt too. It's as if Notepad++ was trying to access something on the network or Internet. I'm on a WIndows network with Domain login. Also, I have the notepad++ feature turned off to open the last file I had open when I closed it too. Hmmm – Eric Nov 24 '15 at 14:46

In spite of the notepad++.exe (with its 13 process) presence is the tasks manager...

Forgive me if I miss understand this statement but you're saying there are 13 notepad++ processes running?

If so I'd say one of them (probably the first/original) is stuck/unresponsive/otherwise occupied.

Kill all of your notepad++ processes and restart the application. Restarting your computer should have the same effect.

One final note, notepad.exe has nothing to do with notepad++ and is Windows' built in text editor, screwing with it won't fix this third part app.

share|improve this answer
    
Thank's @Windos, I killed all notepad++ preocesses and restarted application, but there is again the task only. I tried to re-install notepad++ 5.9 and 5.6.4, the problem still – Dsandre Aug 11 '11 at 9:24
    
It's very strange because after the installation notepad++ window launch automaticaly, but when closed it's impossible to restart – Dsandre Aug 11 '11 at 9:27
    
@Dsandre, have you done a full restart of you PC after all this installing? – Windos Aug 11 '11 at 9:29
    
Yes I did, but I also tried to do this without restart the computer – Dsandre Aug 11 '11 at 9:30

I would recommend you to do the following:

  • Open task manager
  • Terminate all instances of Notepad++. (Not to confuse with Notepad.exe)
  • Open command prompt (cmd)
  • (If necessary) navigate to your notepad++ installation directory
  • Start Notepad++.exe using the following command: Notepad++.exe -nosession.

If it is the problematic file that you have previously opened and it was preventing notepad from starting up, the -nosession argument should resolve it.

share|improve this answer

For my case, it was caused by a setting I recently changed.

From menu: Settings - preferences - MISC tab - at right bottom corner, I put "xml" in Session file Ext field for save session file convenience.

I did not realize this would cause the xml file to be unable to open in Notepad++.

share|improve this answer

I just ran into a similar issue where Notepad++ would launch, show in the taskbar, but not display on screen. This happened after I had logged into my computer through remote desktop from another PC.

I was able to fix it by alt-tabbing to the process and then use [windows key]+[left arrow] to move the window to my main monitor.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .