Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I have been experiencing severe latency issues when doing certain network transactions. I have narrowed the issue down to the domain secure channel between the workstation and the domain. I say this because when I right check the Security settings of any file/folder that has domain added users/groups, I get a listing like this:

file properties window

Notice the 'S-1-5-21-35......'? This takes close to 30 seconds to populate and it doesn't stay there permanently once populated (when I leave the dialog and come back in a couple minutes). This causes severe latency with certain applications that hang because of this. When I try to click 'Add' I get two new errors:

error window 1

"The program cannot open the required dialog box because no locations can be found. Close this message, and try again."

error window 2

"Unable to display the user selection dialog. The parameter is incorrect."

I have tried using the Microsoft Windows NT 4.0 Resource Kit using the "nltest /SC_RESET:[domainname]" command and I just get an error:

I_NetLogonControl failed: Status = 1311 0x51f ERROR_NO_LOGON_SERVERS

It also errors out when I try the /SC_QUERY command as well.

I have tried removing and adding the machine to and from the domain. It is only this user on this machine, any other user on the machine works fine and the user works fine on other machines.

The machine is running Windows XP SP3 with all the latest Microsoft Updates. I do not recall doing anything before this issue occurred that would cause it.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

It ended up being the DNS server configured for the workstation. It was setup manually on the machine with DHCP enabled for IP address assignment but a static DNS set to Google. So the latency was a result of the machine querying for machines on Google's DNS server instead of the internal one on our Windows Server.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.