Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Login as user myuser.
To become root and run Android SDK manager:

su -  
/var/lib/jenkins/android-sdk-linux_x86/android  

all is well.

Then to become user jenkins and run Android SDK manager:

su - jenkins  
/var/lib/jenkins/android-sdk-linux_x86/android  

fails with

SDL init failure, reason is: No available video device

Logout. Login as user jenkins.

As user jenkins:

/var/lib/jenkins/android-sdk-linux_x86/android  

all is well.

So, when I su - jenkins it does not work, but when logging in as jenkins into gnome it works.

How can I start the Android SDK manager with non-root shell?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Sounds like a permission problem.

Check the permissions on the file. Make sure that you are either an owner or part of a group with write permissions for the SDK path. The binary will need permission to read and write to the sdk path also.

adb is the only service I've had to run as root. The purpose for that is to be able to find and manage the devices that have been plugged in. There is even a way around that as well by setting up a rule with udev.

share|improve this answer
1  
You're right, it is a permission problem. Running "xhost +" before doing "su - jenkins" solves it on the commandline. –  user19496 Aug 11 '11 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.