Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a Windows 7 system (Host PC) running Virtualbox, I am trying to install CentOS 5.6 (x86_64 a.k.a 64-bit version) server.

I tried a couple of installations, since most people I asked for help told me to "learn by doing and failing." Unfortunately I am only failing at this time.

I've got lots of doubts right from the beginning, hope you can help: (NOTE: I am trying to setup a CentOS LAMP server, where I'll install a wordpress website, which should be accessible to anyone on the web, like you and me, when I switch on the system. I hope you understand?)

  1. Mine is a LAN (8mbps broadband) connection, unlike those 100/1000mbps high-bandwidth connections these Hosting companies get. Can still setup a public server?
  2. At this point during the installation (see screenshot)... the option to encryption offers more security. But will enabling it prevent people from being able to access my website? or it doesn't matter? If so, why doesn't any hosting company that I know of do this by default?
  3. At this point during the installation (see screenshot)... I don't know what to put in the fields shown - - IP Address and Prefix. (here's my ipconfig details - - see screenshot). What should I put in the given fields?
  4. First (see screenshot)... are these fields correct?
    • manually: host1.comicb.us - - I own comicb.us domain and that's where my test blog is going to be.
    • Gateway: 192.168.1.1 - - according to my ISP
    • Primary DNS: 218.248.255.139 - - according to my ISP
    • Secondary DNS: 218.248.255.142 - - according to my ISP

I reason why I said my installation is failing is because, my server is unable to connect to the internet. I tested this by pinging google.com. Obviously, the error should be in one of the above.

share|improve this question
3  
I wish people didn't learn to setup public servers "by doing and failing". I mean no offense to you, but I see a zombie machine in your future. –  Jason Berg Aug 9 '11 at 20:21
    
@Jason Berg yeah me too. But that's the advise I got, instead of some help. –  Aahan Aug 9 '11 at 20:22
    
Per your request, I pasted in text from this raw data from pastebin –  Stefan Lasiewski Aug 9 '11 at 20:28
    
@Stefan Lasiewski Thanks a lot. Just what I wanted. Now... someone please help me with my doubts?? –  Aahan Aug 9 '11 at 20:30
    
All the images are broken. Can you reupload them with the provided image uploader if you still have them? –  8088 Sep 3 '11 at 7:20
add comment

migrated from serverfault.com Aug 11 '11 at 18:49

This question came from our site for professional system and network administrators.

2 Answers

up vote 1 down vote accepted
  1. It is likely this will work. It may be a little slow though. Some ISPs don't like home servers.
  2. No, once your system is running then services within can read the filesystem.
  3. 192.168.1.100 and 255.255.255.0 is probably as good as any.
  4. I would name the machine host1.comicb.lan. To access your machine via it's host1.comicb.us name you will need to set the DNS A record to point to your PUBLIC IP address and have your ADSL modem/router port forward port 80 to 192.168.1.100.

You should also ensure that you have your VirtulBox guest's network adaptor configured as Bridged Adapter this should then put your guest on the same network as your host.

share|improve this answer
    
3. 192.168.1.100 and 255.255.255 is probably as good as any. - - you are probably considering the values in the image. That image is from the tutorial. my ipconfig details are here - - (see screenshot). So what should be the values now? –  Aahan Aug 9 '11 at 20:54
    
I missed the .0 off the netmask otherwise as stated. They are in the same network and .100 is far enough away from the ends that it's unlikely your DHCP server will use them. –  Iain Aug 9 '11 at 20:59
add comment

You questions are kind of silly, so I suggest you read up before 'doing and failing' otherwise you won't know what to try and won't understand why and where you failed. Secondly, I would like to mention that unless you have a business grade plan, your ISP will most likely block most common ports like 80, 25, etc so people won't be able to connect to your server unless you run it on some wierd port.

1) You also have to understand that you according to your screenshots, you are running behind NAT so your server won't be accessible from outside anyways. 192.168.x.x range is for private networks only. It's not routeable over internet. However you can still test your server internally(and that's what you should be doing until you get more familiar with everything)

2) Leave it unecnrypted for now - partition encryption doesn't really have anything to do with what you are trying to achieve.

3) It looks like you might get away with using DHCP for now and having your router provide your server with all the neccessary details. Or use 192.168.1.5/255.255.255.0

share|improve this answer
    
Any suggestions as to what I should read? I have checked some CentOS books, but none had any clear information about these. Just the installation process. –  Aahan Aug 9 '11 at 21:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.