Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to set-up a test environment for a PHP web application on a windows 7 system. I'm using the NetBeans IDE with the Selenium PHP plugin and PHPUnit installed on a local web server (XAMPP). I have everything set-up, except that the Selenium server that's bundled with NetBeans gives the error:

Failed to start new browser session: Error while launching browser.

Every time I try to run a test.

Now, I'm pretty sure this is a UAC issue, as I was able to make the tests run by stopping NetBeans' Selenium server and starting one from an administrator command prompt. What I'd like to know is if there's any way of making the NetBeans plugin work, preferably without disabling UAC.

addendum: I've also tried running NetBeans as Administrator, and setting it to always run as Administrator in the properties, neither of these worked.

I realise that asking this when I already have a workable solution seems a bit perfectionist/OCD, but we probably wouldn't be on SuperUser if we weren't a bit perfectionist/OCD anyway. No?

Oh yes, and if it's not possible than I'd appreciate being told why it is not possible... I understand Unix-style permissions but this whole UAC thing is still a mystery to me.

share|improve this question
    
If you (just) disable UAC, does it work as expected? (With/without Run As Administrator) –  Ƭᴇcʜιᴇ007 Aug 11 '11 at 21:13
    
    
@techie007 I tried this, sadly it did not work. –  Li1t Aug 14 '11 at 12:55
    
@Ian Boyd Hmm... The firefox profile thing has promise, it could explain why running the process as a separate user (Administrator) might have worked, except that it doesn't work when Firefox is closed either. Also, I think the problem is with Selenium launching rather than Firefox starting, as it can't launch IE either. –  Li1t Aug 14 '11 at 13:03
    
If running an app with UAC disabled (as admin) and it doesn't work, then it's not a UAC problem. –  Ƭᴇcʜιᴇ007 Aug 17 '11 at 12:05

1 Answer 1

It's a separate process you are launching, so it triggers the UAC prompt. Without knowing more details of your setup, this would be impossible to diagnose.

Instead of disabling UAC, you can use Microsoft's Application Compatibility Kit to disable UAC for your plugin. . .

http://www.microsoft.com/download/en/details.aspx?id=7352

share|improve this answer
    
Hi surfasb. Sadly I've now tried both the compatability kit and disabling the UAC prompt - these did not work. Also, I noticed that the process ID that's running the selenium server is the same as is running the parent program (NetBeans) so I think it's a Java thing. –  Li1t Aug 14 '11 at 12:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.