Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed a version of nLite on a computer, and after booting I noticed that a few things went wrong.

  1. The theme was Windows 2000
  2. None of the applications I had told nLite to install had installed
  3. I could not switch the "Luna" theme
  4. I could not install all of the applications, and would get the error "The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance."
  5. When trying to install Google Chrome I got the error "Google Update installation failed with error 0x800706ba," whether with the standalone installer or the regular one.

Unfortunately, I am my support personnel, so no help there.

The only services that are being started (despite most being set to "automatic") are:

  • Cryptographic Services
  • Plug and Play
  • Remote Procedure Call (RPC)
  • Windows Audio

Additionally, I can't run msconfig.

This problem is similar to this question, but I only got this working after much trouble and strife, and quite a bit of luck, so reinstalling won't work. Not to mention the fact that I can start the services at all, attempting to start them gets partway done, then stops. The status in the Services window says "Starting," and stays there.

Is this the same problem? Is there another way around it? Could my nLite commands have caused critical systems to stop functioning?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Well, considering that the point to nLite is to strip Windows down as much as possible, and that if you make a misstep, the installation will be corrupt, then yes, I would say that you configured something, somewhere wrong such that the installation you ended up with was not complete or sufficient enough for a proper install of Windows. What’s more is that you yourself admit to having a lot of problems and strife trying to get it to work, which is an even bigger indication that the installation you produced is no good.

Further, the services were not actually getting “partway done, then [stopping]”. That would imply that they were successfully starting for a bit then getting stuck. What’s more likely is that a part (eg a thread) was crashing (silently) or having trouble locating dependencies and simply not failing immediately. Again this is likely because of too much getting stripped out.

You’re not getting Luna because it needs the Themes service to be running, which is clearly not the case for the aforementioned reasons. Google Chrome won’t install because it too requires some services to be running which your system is having trouble doing. The same goes for the Installer service.

The service that you do have running are indeed the bare minimum that is required to have Windows XP run (actually you can forcibly kill the Audio service without killing Windows). You just stripped out too much.

I’m afraid that your best bet is to reinstall with either a standard install, or at the very least to re-configure nLite, watching carefully what you strip in order to avoid taking out required components.

If you really insist on trying to fix your broken install, it will be a heck of job since you have no way of knowing what files, registry entries, services, etc. are missing. What you could try is to use some programs such as Filemon/Regmon/ProcMon to monitor the system while you try to start a service or run an app to see what items are being accessed to try to figure out what is missing, then try to find a way to add/install the missing items. (Note all the tries.)

share|improve this answer
    
I’ve done a lot of Windows-pruning myself and had plenty of problems. Of course for me, figuring out what was wrong and fixing those problems was almost as much fun as cutting it down was in the first place. Also, I usually did the stripping on normal, full install, so I was at least sure that it started out working and any problems were likely from the last thing I removed, thus making it easier to fix. ;-) –  Synetech Aug 12 '11 at 4:06
    
"Could my nLite commands have caused critical systems to stop functioning?" I think this sums it all up. Nothing worth doing is easy. . . –  surfasb Aug 12 '11 at 9:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.