Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It should probably come as no surprise that their are certain files I don't want to appear in "All My Files" EVER. How do I get Mac OS X v10.7 (Lion) to ignore specific folders for its "All My Files" feature?

share|improve this question

migrated from Aug 12 '11 at 1:51

This question came from our site for system and network administrators.

Put them somewhere else. runs – Ignacio Vazquez-Abrams Aug 12 '11 at 1:49
What part of "all my files" don't you understand? :) – Spiff Mar 19 '12 at 16:21

3 Answers 3

I figured it out. Go the System Preferences -> Spotlight -> Privacy.

Drag in the folders you don't want indexed. They get removed from the "All My Files" feature.

share|improve this answer

EDIT: This does not appear to work in Yosemite (10.10) or Mavericks (10.9). At the time the question was asked, Mountain Lion (10.8) was the current operating system at the time.

This would work, but is a little bit of overkill.

If you Ctrl-Click on "All My Files" in the Finder window, you can edit the search >that "All My Files" does without changing your Spotlight preferences.

share|improve this answer
It doesn't include all of the criteria though. You could also edit /System/Library/CoreServices/‌​nts.cannedSearch/search.savedSearch. – ؘؘؘؘ Sep 3 '12 at 7:17
This does not work. When I Ctrl-Click I don't get an option to edit. I am running Yosemite. – Siraj Apr 22 at 3:19

The easiest way that I have found in Yosemite is:

  1. Go to System Preferences->Spotlight.
  2. Click on the Privacy Tab.
  3. Under "Prevent Spotlight from searching these locations", Drag your iCloud Drive Folder into the list.

    • Your iCloud Drive is located at Users~{username}~Library~Mobile Documents

    • Any other folders that you do not want to be visible in "All My Files" can also be added to this list.


If iCloud drive disappears from the finder sidebar, you can re-enable it if desired by:

  1. Open a Finder Window.
  2. Click Finder->Preferences.
  3. Check "iCloud Drive" under Favorites

Now you should still have a link to the iCloud drive in the Finder sidebar and the contents of your iCloud drive will NOT show up under "All My Files"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.