Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Got a Cisco Sipura SPA 941 hardware phone and I am connected to Asterix (most likely) VoIP server of my provider.

I am behind a firewall (ADSL) and I have put my phone to the DMZ zone, so it should be reachable from the internet.

Now I can make calls without any problems, but when somebody calls me I can hear it ringing, but when I pickup the earphone, nothing happens and I see "Answering Call" on the display. On the other side of the line I still hear its ringing.

Now question to all superuser VoIP experts: what option should I search on my phone to chage to get this working? My friend gave me advice DMTF (got Auto), tried all options without any luck.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Even in a DMZ, the firewall can affect sip signaling, or there may be issues within another device down the line. For example, you may have the phone in a DMZ on your own router, but your ISP has a routed modem and that device is selectively blocking some of the sip signaling (ALG, SPI, Intrusion Detection) which is not allowing the phone to acknowledge to the server that it has picked up the call, even though locally you have. This is very very very common. I have even seen instances where the ISP has an ALG setup on their core routers that has intermittently blocked the ACK signal from the phone on an invite, causing that exact problem.

To put it simply, make sure that ALL devices have ALG, SPI, and Intrusion detection disabled. Also make sure that cisco specific ports are open in all devices between your phone and the voice server. This may require a call into your ISP to clear the entire path (if you have your own router and your ISP is able to bridge the modem, that is usually a huge help).

If your voip provider can get you the call ladders for the issue, I can take a look and tell you where the signaling is failing (though they really should be able to tell you that too).

share|improve this answer
    
Many thanks for tips. I know what is intrusion detection, not sure about ALG, SPI. Will try to find that on my router. My ISP tells me to open the following ports: TCP a UDP 5060, RTP 10000-20000 –  lzap Aug 15 '11 at 11:17
    
So I found ALG section there, I only have "SIP" enabled there. So according to your advice I am disabling it right now. There's also intrusion thing ("Enable DOS and Portscan Protection") but I have it turned off. –  lzap Aug 15 '11 at 11:22
    
I CANNOT BELIVE IT BUT UNCHECKING THE "SIP" OPTION HELPS! MANY THANKS! THANK YOU THANK YOU THANK YOU :-) –  lzap Aug 15 '11 at 11:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.