Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do you recover a file which (I trust) was backed up by Time Machine when Time Machine refuses to show the directory?

Specifically, I can't get Lotus Notes to start. (Yes, I know; I don't much like it, but it is required.) I was thinking that I should be able to recover the last known working version from Time Machine, but the file is in:

/Users/jleffler/Library/Application Support/Lotus Notes Data/mail6/jleffler.nsf

and when I go into Time Machine, it is not showing the Library directory at all, which makes it hard to recover the file from that directory. At this stage, I'm not even certain that the file is backed up, but I have to assume it is and I'm overlooking something obvious.

share|improve this question

migrated from Aug 12 '11 at 20:09

This question came from our site for professional and enthusiast programmers.

Is there a particular reason this should not have been asked on SU? – Bill the Lizard Aug 12 '11 at 19:56
@Bill: possibly not - I debated, and decided to ask where there are the most eyes. I go to SU maybe once a month, if I'm feeling diligent. – Jonathan Leffler Aug 12 '11 at 19:58
Okay, I wasn't sure if Time Machine was maybe commonly used as a source code repository or something. Should I move this to the Apple site or SU? – Bill the Lizard Aug 12 '11 at 20:01
@Bill: your last question shows why the fragmentation of the sites was a disaster -- there isn't a single place to look for the answers to questions, thus making it much, much harder to work out where to look. I've not been to the Apple site before - that's, I suppose? – Jonathan Leffler Aug 12 '11 at 20:14
Yes, that's the one. – Bill the Lizard Aug 12 '11 at 20:27
up vote 10 down vote accepted

Have a look at turning on hidden file display in Finder and then going into Time Machine

In Terminal

defaults write AppleShowAllFiles YES

This sets the flag to show hidden files

killall Finder

This will force Finder to restart

Then go into Time Machine, fix/restore what you want and then

defaults write AppleShowAllFiles NO

killall Finder

To go back to blissful ignorance

share|improve this answer
I like the 'back to blissful ignorance' part of this! I suspect that 'defaults delete AppleShowAllFiles' might be better than setting it to 'NO' given that the flag is not set at all locally before I started on the changes. – Jonathan Leffler Aug 12 '11 at 20:00
I'd say leave it. That way you can use a plist editor to toggle it rather than remember the exact key - I had to look it up myself for this answer. – Abizern Aug 12 '11 at 20:02
The free utility TinkerTool, gives you a graphical user interface for turning hidden files display in the Finder on or off any time you choose. It has many other functions besides; it's basically a GUI front-end for all kinds of routine command-line operations. – user93417 Aug 14 '11 at 18:45
Note it's killall Finder (capital F). – Ash May 21 '12 at 22:31
@Ash Thanks. You're quite correct. – Abizern May 21 '12 at 23:19

That is most likely a local copy of your mailfile, you should be able to pull down a new copy of it from the server, just missing that nsf file shouldn't prevent Notes from running.

share|improve this answer
I managed to recover the backup file, and it made no difference to the misbehaviour of Notes. So, I've probably got some problem with Java (again) on MacOS X Lion. But I am not sure what changed between the date when it worked and the date when it didn't. – Jonathan Leffler Aug 14 '11 at 16:26
Do you know what version of Notes you have? You may see if this technote applies – Zach Aug 17 '11 at 0:36
I've now got 8.5.3.CD5 (an internal pre-release). It is working for me once more (on both MacOS X 10.7 this morning and 10.7.1 this afternoon). I tried an 8.5.2 version and it had troubles. It might easily have been the problem diagnosed in the tech note you reference, though; the description sounds plausible. Thanks for the information; it strongly indicates I was running into a real problem, not something I'd created for myself (other than by upgrading to Lion). – Jonathan Leffler Aug 17 '11 at 0:52

You must log in to answer this question.

protected by nhinkle Jul 13 '13 at 5:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .