Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I asked Spotlight not to index Documents, but I keep getting full lists of programming files, like *.c *.h and all kinds of developer files

And its not just in one folder, its all over the place, so I can't use the Privacy filtering to stop this indexing.

How do I stop this? I am using OS X Lion

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Those are "Developer" items:

I can disable it in System Preferences (16):

enter image description here

However, I've read that some people can't disable Developer as they don't have the option on forums and what not. I do have an iCloud beta installed, so maybe the public release of Lion doesn't have that option, I'm not sure. I can eliminate all my .m and .h files from popping up.


If you don't have the GUI:

Navigate to com.apple.spotlight.plist (~/Library/Preferences) (You may need a file revealing app for this, like this which I wrote, teehee), open with a text editor, and add right before the </array>

<dict>
    <key>enabled</key>
    <false/>
    <key>name</key>
    <string>SOURCE</string>
</dict>

If you already have a key value named "SOURCE", replace <true/> with <false/>. It's probably near the bottom.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.