Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This isn't SO much a problem, since I can make it work, but still I am curious as to what causes the issue.

I have an old HP Compaq desktop pc, and recently put a 2TB drive in it. Now most recently, the drive was formatted by an Ubuntu install "erase and use the whole disk." I'm not quite sure if it's relevant, but that means the disk is gpt partitioned, with the first partition being the bios_grub partition.

When I'm booted into the OS, everything is going fine. Then I shut down, EITHER from a power failure or a formal shutdown. The next time I boot, the BIOS greets me by saying "the following settings were changed:" then proceeds to list the CD-ROM (which never actually changes) and the Hard drive, which is listed as 0.00TB.

When this happens, I can boot into a live CD, and shut down again, and then the BIOS greets me with the same message expect that it's recognized that it's 2.00TB again. Then booting from disk works.

This process will repeat.

What could possibly cause this bi-polar behavior in the BIOS?

EDIT! :

I've just determined that that it re-recognizes the drive as 2.00TB ONLY if I reboot out of the live cd, NOT shutdown. I'm going to test real quick what happens if I reboot out of the OS on the disk.

Strange issue.

Yep. To get the BIOS to recognize the disk as 2TB, I have to reboot out of something. If I shutdown or force shutdown, the BIOS thinks the disk is 0TB.

What could be causing this?

share|improve this question
    
Have you considered or tried updating the BIOS? "Compaq" computers died LOOOONG before 2TB drives were available. :) Have you tried testing with the CD-ROM detached? –  Ƭᴇcʜιᴇ007 Aug 12 '11 at 23:38
    
Updating the BIOS may indeed make my life easier. I've never done that before, but heck I got the thing for 60 bucks just so I could hack around with it. Could you direct me to some resources on that? Flashing the BIOS sounds particularly ... dangerous. –  Chase Meadors Aug 12 '11 at 23:40

1 Answer 1

Try updating your BIOS.

http://support.hp.com

Find your model, download the BIOS updates (if any are available) and read the instructions/warnings.

It's pretty straight-forward usually; action may range from making a boot disk, to just running an .exe; depends on the model of the computer. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.