Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use screen and I use utf8 with this in my ~/.screenrc

# utf-8
encoding utf8 utf8
defencoding utf8

ok. But, when I reopen screen with

screen -x 

screen don't show the utf8 characters

EDIT

I use OSX Terminal, but the problem is when I connect to ubuntu over ssh

my locale output

LANG=es_ES.UTF-8
LANGUAGE=es_ES
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=C
share|improve this question

Use the -U flag to run screen in UTF-8 mode:

screen -U
screen -Ux
screen -Ur

See also: http://stackoverflow.com/questions/4606570/os-x-terminal-utf-8-issues/

share|improve this answer

What terminal program are you using? Does your terminal program support UTF-8 as well? In Konsole, you can check using View > Set Encoding. PuTTY has this as well in its settings.

Does your shell really output UTF-8? Check using locale command.

share|improve this answer

According to your posted output of locale, the problem is that you have $LC_ALL set to "C", and this overrides all other settings with a generic, non-UTF8-capable locale.

Find out where LC_ALL is being set (likely ~/.*rc or ~/.*profile), and remove it – on both OS X and Ubuntu. Then log out and log in again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .