Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I face this problem very commonly whenever I install the fresh Windows 7 it works only for a week or may be twice but after that it gives me error and all the time I've to run it through the run command.

enter image description here

This link tells me to store default extension but I don't know which should I've to run to fix it.

share|improve this question
2  
You want the MSC REG file on that page. –  Synetech Aug 13 '11 at 5:03
    
The compmgmtlauncher.exe is giving the same error while I'm trying to access it directly from the path. –  avirk Jun 2 '12 at 2:24
add comment

1 Answer

You want the MSC REG file on that page.

You may also want to view what association is set for MSC files to figure out why it is being changed. Check what program is associated with it and maybe you can set that program to stop taking the filetype. (For example, whenever I use the associate command of XMPlay, I have to make sure to un-check .MSC because while there may be some music files with that extension, I only ever use that extension for Mirosoft Common Consoles.)


A diagnostic step you can try is to use Process Monitor. Run the program, then stop the capture with Ctrl+E (if it’s not already stopped). Press Ctrl+L and add the following two capture filters:

ProcMon filters for .MSC and mscfile

Next, select only the Registry class filter as shown:

ProcMon class filters for Registry

Now, clear any capture data with Ctrl+X, then start the capture with Ctrl+E. Finally, Run devmgmt.msc.

Wait for the Device Manager to start, then switch back to Process Monitor and stop the capture again.

Now either get a complete screenshot of the output (like below, expect full), or even better, File->Save the capture dump to a PML file. That way I can check to see what the heck is being accessed and where it is failing. You can upload to any file-dump site.

Sample ProcMon capture from running devmgmt.msc

share|improve this answer
    
I tried with MSC Reg file but still the same error is occurring. –  avirk Aug 13 '11 at 7:01
    
Did you reboot? Did you check the current filetype-association? –  Synetech Aug 13 '11 at 7:04
    
No I didn't rebooted the system as generally I don't restart after adding registries. I'll respond you after restart. –  avirk Aug 13 '11 at 7:06
    
Nopes it doesn't fixed it. Now how can I check association for msc. –  avirk Aug 13 '11 at 7:16
    
.Msc is associated with Microsoft Management Console. –  avirk Aug 13 '11 at 7:19
show 10 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.