Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded to Mac OS X 10.7 Lion. When I go to access a Juniper Networks Secure Access page which uses the Java Secure Application Manager (JSAM) to login to my works VPN I get an error saying that Java for Cocoa is not available. The error is:

"This browser does not use the Cocoa java Plug-In. 1) Make sure that JVM 1.4.1 or later is installed 2) Check that this browser supports Java for Cocoa (such as Safari)"

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Yes I am answering my own question, I spent 4 hours searching and messing around and figured I would post this to help someone else...
The answer is that it is possible to get it working, you have to reinstall java and safari from snow leopard. Instructions below, taken from this discussion: https://discussions.apple.com/message/15760121#15760121

Better explaination:

1) Download and install Pacifist from: http://www.charlessoft.com/Pacifist.dmg
2) Download and Mount JavaForMacOSX10.6Update5 from http://support.apple.com/kb/DL1360
3) Download and Mount JavaForMacOSX10.7 from http://support.apple.com/kb/DL1421
4) Launch Pacifist and select Open Package
5) Select the mounted JavaForMacOSX10.6Update5.pkg
6) Hit install, when it prompts always select "Replace"
7) After it is complete, select Open Package and select the JavaForMacOSX10.7.pkg
8) When it prompts select "Replace"
9) You can copy Safari 5.0.5 from SL or if you do not have access to a SL machine
10) Download and mount Safari 5.0.5 from http://appldnld.apple.com.edgesuite.net/content.info.apple.com/Safari5/041-0564.20110413.Fi9pb/Safari5.0.5SnowLeopard.dmg
11) In Pacifist select Open Package and select the Safari 5.0.5 pkg file
12) This time select Extract and place it onto your desktop
13) Go to the Safari5.0.5SnowLeopard folder on your desktop, inside of that you will see an Applications folder, open that and you will see Safari, you can rename this Safari, I named mine Safari 5.0.5 and copy it to your main Applications folder or whereever you want.
14) Launch this Safari and go to About and make sure it says 5.0.5
15) Try your Secure App Manager.

share|improve this answer
add comment

A bit late I know, but I have just had to solve this for someone and I think I have a simpler solution. The error message is produced by some javascript that just checks for a particular plugin by file name - one that no longer comes with Safari 5.1. If you go to http://www.ugh.net.au/~andrew/jsam.xhtml and download the dummy JavaPluginCocoa.bundle it gets you past the script and everything seems to work fine. It saves you having to run an out of date web browser (with potential security issues) if nothing else.

share|improve this answer
add comment

I was able to solve this with the help of my IT department. Since Apple doesn't support Java any more we need to figure out a few things. First ensure that you have the latest version of Java down loaded for the Mac. After you do that you will need to follow these steps.

Open your system preferences in the top left corner and go to the Java tab and select view. There you will find the version of the Java and it will already be selected or checked. If so go over to the Security tab and unselect the Enable Java content in the browser and then reselect this item.( The IT person said this does something but I didn't notice anything). Then Proceed to JavaTester.org in Safari and automatically you will see what Java version you are using. You may have to refresh multiple times to eventually see your Java Version show in the pink box in the center of the screen. After you have see your version you may have to locate your Network connect and uninstall this. Once you remote in you will automatically reinstall network connector application and you should no longer get the Java coco error message.

Hope this helps,

David

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.