Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need help/guide how I can open my ssh access from a GUI or Filezilla.

Here's the scenario my developer just left me with the login info to my Amazon EC2. Now I am finding difficulties in understanding all this stuff. I used PuTTy and command prompt just to connect to my server using ssh process. It uses some bridge process just to connect to my actual server.

right now he provided me 2 sets of login.

[Set1]

  • bridge.hisdomain.com
  • username
  • somepassword

[Set2]

  • ssh username@123.456.789.123
  • somepassword

[my process]

in [Set1] I enter "bridge.hisdomain.com" in the hostname of PuTTy. after I hit Open It will open a terminal and will asked for a username. thats where I provide my [Set1] username and password.

Ounce login, I then perform [Set2] Details. I will use "ssh username@123.456.789.123" after I enter it, It will then asked for my password.

from there, when I do "DIR" in command prompt I will see al my files there. I wanted to download a directory there to my local drive but I am not familiar with the commands.

I would like to access it just by using FileZilla or similar. And I've also tried this but I don't know what I'd miss, because It didn't work for me. I downloaded a .pem file from the [set1] because I can also access it using a regular FTP (filezilla) and I then converted that .pem file to .ppk.

right now I'm kinda confuse what login info I should use for my FileZilla to access the server. I had success in loging via FTP using [Set1] login details. But my files aren't there. I only saw some folders and a .pem file.

I can't login to my Filezilla using [set2] details. I tried FTP and SFTP. I also added the .ppk file in the settings of my fileZilla. But I had no success in loging in.

any ideas what did I miss?

share|improve this question

migrated from serverfault.com Aug 13 '11 at 15:45

This question came from our site for professional system and network administrators.

5 Answers 5

up vote 4 down vote accepted

I use WinSCP instead of FileZilla to transfer files to/from my EC2 instance. Logging in with a PPK file is very simple. In addition, WinSCP provides a very nice GUI (I use the version that looks/acts like the regular Windows Explorer interface).

Note the PPK file is associated with the username and password from [Set2]. [Set1] simply connects you to a computer that has the credentials needed to access the EC2 instance. Since you transferred the *.pem (ssh private key) file, you should not need to use [Set1] anymore.

update:

Your developer may have configured your EC2 instance to only accept connections from bridge.hisdomain.com. Go to the AWS management console to see if that is the problem (Note the AWS account username and password are probably different than any of the passwords above):

  1. First, find out which security groups your EC2 instance is a member of.
  2. Then find out which inbound connections are allowed for those security groups.
  3. You need to find/add a rule that allows port 22(SSH) from your IP address.
  4. This source IP will allow all SSH requests from anywhere: 0.0.0.0/0.

Alternatively, you can try making an ssh connection from your local machine to figure how why the sftp connection is not working. Use Plink, the command-line version of Putty, with your PPK file and the -v option (for verbose.)


The process for using FileZilla with a PPK file seems quite convoluted. (Hint: you give your password to Pageant, not FileZilla! If you insist on using FileZilla, follow the instructions below:

Now run Pageant. In your system tray, you'll see the Pageant icon appear. Right-click the icon and select "Add Key" and select your private key (PPK) file. Follow the prompt to enter your pass phrase and you're done.

Now simply launch FileZilla and connect to your server using SFTP using SSH2 with a username and an empty password.

share|improve this answer
    
I did follow this instructions "Logging in with a PPK file" but I can't seem to access it. my hunch is, I maybe not doing it right. my developer provided me this detail: "ssh username@123.456.789.123". I am guessing the User Name for my WinSCP is "username" and the host would be "123.456.789.123". My PPK is also already linked up. but I can't seem to connect. any ideas? –  Pennf0lio Aug 14 '11 at 6:48
    
When I connected to the [Set1], I saw a .ssh directory and its containing a "known_hosts" file does that affect to the way I access the server? Is it filtering me? Thank you very much Leftium! –  Pennf0lio Aug 14 '11 at 6:51
    
@Pennf0lio: Since you already have a PPK file (downloaded from [SET1]), just follow the last three steps. Make sure you enter your password in the correct place (Not in the WinSCP login dialog "password" field! But in the "Enter Passphrase" box that pops up after selecting your PPK file.) One issue may be your developer locked down the EC2 instance so connections are only possible from the "bridge" domain. I added some details to my answer. –  Leftium Aug 14 '11 at 15:01
    
thanks so much in taking time for helping me. I am not able to access Amazon console since the developer didn't provided me. I think it is not letting me access the [set2] host if its not coming from the [set1] bridge. are there way around? I am able to access the server using command line and using [set1] then [set2] info. But I can't go directly to [set2] without loging in to [set1]. Is there a way I can just download a directory inside terminal? Do I need to use sftp command in the terminal? –  Pennf0lio Aug 15 '11 at 4:52
    
basically for now I just want to download a directory to my local folder. that directory contains my server files and other files. any ideas? –  Pennf0lio Aug 15 '11 at 4:55

Some SFTP clients (like FileZilla) store all the SSH certificates in one pool and will try SSH certificates in sequence, so make sure your setting in /etc/ssh/sshd_config for "MaxAuthTries" is set high enough to include the "maximum possible" certificates you have in your SFTP client.

share|improve this answer

The following tutorial on YouTube walked me through the complete process (successfully! and in less than 10 minutes): http://youtu.be/QYDvtLofrtM

I am on MacOS, so when this tutorial prompts to open 'Edit'/'Settings' in FileZilla (presenter is on Windows), if you are on a Mac like me, then instead go to 'Filezilla'/'Preferences'

share|improve this answer
    
It would be good to summarize the finer points of the video here and provide the link for reference, other sites (and videos) are prone to disappearing and deletion over time. –  Mokubai Jan 25 '13 at 18:02

To connect to a running Amazon EC2 instance with Filezilla:

  1. Edit -> Settings -> Connection -> SFTP
  2. Click "Add keyfile..."
  3. Browse to the location of your .pem file and select it.
  4. A message box will appear asking your permission to convert the file into a supported format. Click Yes, then give the file a name and store it somewhere safe.
  5. If the new file is shown in the list of Keyfiles, then continue to the next step. If not, then click "Add keyfile..." and select the converted file.
  6. File -> Site Manager
  7. Add a new site wih the following paramerters:
    • Host: 123.456.789.123
    • Protocol: SFTP
    • Logon Type: Normal
    • User: username
  8. Connect to the new server
share|improve this answer
1  
Thanks for step by step instructions, based on above steps i was able to connect successfully, this is step by step video guide created based on above. y2u.be/e9BDvg42-JI –  Yasitha Chinthaka Nov 1 '13 at 2:24
    
@vmerror: Nice tutorial! Why no link in the description to this question? –  dotancohen Nov 13 '13 at 9:33

I was tinkering with Filezilla tonight and FINALLY managed a connection - in Active mode, no less. Here's how to do it:

  1. Set the IP address (Edit -> Settings -> Active Mode -> Use the following IP address:) to the private one from your AWS dashboard
  2. Set passive mode (Edit -> Settings -> Passive Mode) to "Fall back to active mode"
  3. Set inbound SSH port in security groups to port 22
  4. Log in to sftp://ec2-111-11-111-111.compute-1.amazonaws.com/ (replace the 1's with your IP, of course) with your username (no @ or anything) and password, and port 22 selected
share|improve this answer
    
Why was the rest edited out of my comment? Is display of emotion not allowed on this site? lol ;) –  Jeff Apr 21 '12 at 20:58
    
We just prefer a high signal-to-noise ratio. That's what makes the Stack Exchange sites far better than forums for quickly solving problems. –  sblair Apr 22 '12 at 2:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.