Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.
  • VMWare Workstation 7.1.4
  • Host: Windows 7 (laptop with touchpad).
  • Guest: FreeBSD 8.2-STABLE (yesterday's)
  • vmmouse driver: 12.6.9_1 (from ports)

The problem: xev doesn't see mouse back/forward buttons (physically connected to laptop through usb). Wheel is working okay (i.e. 4 & 5 buttons work). FreeBSD thinks that the mouse is ps/2, because there are no /dev/ums* devices.

/etc/rc.conf:

moused_type=auto
moused_enable=YES
moused_flags="-r high"

/etc/X11/xorg.conf:

Section "InputDevice"
    Identifier  "Mouse0"
    Driver "vmmouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/sysmouse"
    Option "Buttons" "7"
EndSection

I don't want to use vmware usb.generic.allowHID option to connect the mouse to virtual FreeBSD through usb because I need that mouse in the host & in the guest at the same time.

Is there any hint how to force vmware or moused or xorg to recognize 6 & 7 button on the "ps/2" mouse?

(It is possible somehow theoretically, because my Windows XP guest (with vmware tools installed) uses vmware ps/2 mouse driver (not the usb one, I checked) and back/forward buttons work fine there.)

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.