Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 2 computers that are about as similiar as they can be

  • Both run Fedora Linux 15 x64
  • Both are behind the same IPv4 only NAT (my house)
  • Both run Miredo (Teredo Tunneling) and have unique addresses
  • Both are using Microsoft's Teredo Server copied from here
  • Both have working IPv6 connections, meaning I can get on sites like
  • Both have their firewalls disabled

In order to do some testing of project though I need to be able to connect to a server running on one of the computers over IPv6. However it doesn't work, the connection just times out (I'm testing with netcat6). ping6ing the other computer times out. There doesn't seem to be any way to have the two computers talk to each other over IPv6.

What could I be doing wrong? The setups are identical, so I'm out of ideas. Does Teredo not allow pinging other Teredo clients? Does both computers being behind the same NAT affect anything?

share|improve this question
And they can ping each other over IPv4, I'm assuming, and you can ping6 a site like My best guess is that Microsoft's server may be cutting out your ping requests - try another provider. – new123456 Aug 14 '11 at 0:18
@new123456 Tried a few other Teredo servers, none allowed the two computers to talk to each other. Even tried having both comps go through different servers, didn't work – TheLQ Aug 14 '11 at 19:53
Did you ever find a solution to this problem? I think I'm having the same issue (except my computers are on different NATs). It's very strange because an IPv6 Port Scanner reports that connections work. – nandhp Mar 24 '12 at 14:08
@nandhp Nope, and honestly now I've given up on IPv6 tunneling. If you do ever find out what to do, others and me would really appreciate it if you posted it as an answer – TheLQ Mar 24 '12 at 21:54
I have the same problem, and my computers are behind two quite different NATs. – EarlGray Nov 27 '12 at 11:55

From here:

A Teredo relay must forward all of the data on behalf of the Teredo clients it serves, 
with the exception of direct Teredo client to Teredo client exchanges.

I'll try to obtain a tunnel through and to see whether connection from behind teredo to my machine behind SixXS will work.

P.S. connection from a machine behind Teredo to a machine behind's AYIYA tunnel does not work either, I don't know why.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.