Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using VirtualBox 4.0 on Ubuntu Narwhal with guest OS Windows XP. I've installed the VB extensions and enabled remote access through port 3389 as suggested on several sites.

I am trying to access this desktop with a Mac OS X 10.5 using Chicken of the VNC. I am not able to connect to the machine using hostipaddress:3389 for my login (and I'm at a loss as to what should go in the password field).

Help?

(P.S. it's not a network connection issue as I can SSH/ftp to this machine okay.)

share|improve this question

3 Answers 3

up vote 7 down vote accepted

VNC doesn't work in this manner because VirtualBox doesn't support RFB; it supports RDP instead. RFB and RDP are entirely different protocols that are not compatible.

  • RFB is VNC's open Remote Frame Buffer protocol -- it uses TCP port 5900 by default, and also serves HTTP over TCP port 5800 to support a convenient client applet written in Java

  • RDP is Microsoft's proprietary Remote Desktop Protocol -- it uses TCP port 3389 by default

You'll either need to use some client software that supports RDP sessions, and/or install a VNC server in Windows XP (and then your Chicken of the VNC client will be able to connect), to get remote access to your virtual Windows XP guest environment.

I highly recommend the famously popular UltraVNC because I've had good experiences with it as a fast and reliable solution in all editions of Windows as far back as Windows XP:

  UltraVNC (free and open source)
  http://www.ultravnc.org/

share|improve this answer
1  
This was very helpful -- thank you. I am not sure that setting up a VNC server in the host OS will allow you to connect to it? I thought the only option was to use VRDP... so for now I've installed Microsoft's RDC on the Mac and am able to connect. Thanks! –  crippledlambda Aug 14 '11 at 3:26
1  
You're welcome. For the VNC Server, I was suggesting that you install it in your virtualized Windows XP guest environment -- you don't need to install a VNC server on the host OS (on which you already have Chicken of the VNC installed {I really like that name, Chicken of the VNC, by the way}). –  Randolf Richardson Aug 14 '11 at 3:30

How about setting a local network using hamachi? I have a windows7 x64 on Athlon x2 3.4Ghz. I installed a virtualbox inside, running w7 x64. They both connect to hamachi network. Thanks to ultravnc, I can control the embedded session. And I can do it also from another pc via wifi connecting the same group. It's working just fine.

You only need to allow ultravnc and hamachi properly in windows firewall and third-party firewall. But it is a bit slow sometimes, surely due to a lack of cpu or latency on my wan. Need to downgrade screen resolution in ultravnc settings.

share|improve this answer

Your best options are:

  1. Find an RDP viewer for Mac (or wait for VB's included rdesktop-vrdp client to become available for Mac). See this for instructions on how to set up authentication:

  2. Use VNC instead of RDP as VB's virtual remote desktop plugin.

share|improve this answer
    
It's nice that one can use VNC instead of RDP to connect to VB machines. Thanks for this suggestion. But there is a limiting factor in the current implementation (as of VB 4.2.6) as it only supports US keyboard from the VNC client. If you use another keyboard, the key mappings are wrong and there is currently no way to solve that. –  Tonin Feb 19 '13 at 14:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.