Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7 Ultimate. WEI scores:

  • Processor: 7.4
  • RAM: 7.4
  • Graphics: 6.8
  • Gaming Graphics: 6.8
  • hard drive: 5.9

AMD 1055T 6-core CPU, generally stays pretty low. 16GB XMS3 DDR RAM, which hovers around 5-8GB used most of the time. Three ATI Radeon HD4670 video cards plus onboard HDMI (at 512MB shared). Everything seems fine.

However, some programs (Notably GoToMeeting and MaxiVista) turn off the Aero Glass functionality. It's still enabled, as in the computer knows it can do it; but it's turned off while these programs are running. How can I force Windows to turn it back on and override the settings from these programs?

I'm also a programmer, so if it involves poking around in the Win32 API, or the Windows Internal Database, etc., that is not out of the question.

share|improve this question
    
Note: I have set registry entries Animations=0, Blur=0, Composition=1, CompositionPolicy=2, UseMachineCheck=0. –  tsilb Aug 14 '11 at 3:33

2 Answers 2

up vote 2 down vote accepted

When using applications that broadcast your screen over a network such as GoToMeeting for MaxiVista, your system will back out of Aero Glass for several reasons including bandwidth / visual artifact reasons.

Most (if not all) screen sharing technologies also don't use your GPU but have a virtual display driver that renders the desktop and streams it over the network.

Microsoft's most recent RDP implementation allows for Desktop composition to show on clients, but this is because the desktop is being rendered on the client machine rather than receiving "video feed" of the remote desktop like many other products do.

share|improve this answer
    
The computers are connected to each other via a single Gigabit switch, I see it go to 1-2% when using them, so somehow I doubt that's the issue. I understand their reasons; I'm looking for a way to override them because I know more about my specific setup than they do. –  tsilb Aug 14 '11 at 4:18
    
Both applications you are using utilize a virtual display driver - it's not rendering on your GPU and will not be able to display Aero glass... Ask GoToMeeting or the MaxiVista people to develop DirectX 9 virtual display drivers. –  Dustin G. Aug 14 '11 at 12:56
    
So no way to override that? Wasn't that WARP technology supposed to allow CPU virtualization of GPU workloads in Windows 7? –  tsilb Aug 15 '11 at 4:14
    
An application must support it... it's not something Windows can force on an application... –  Dustin G. Aug 16 '11 at 3:00

Avoid the registry.

Go to the start menu and type Personalization. Select the Aero theme. If it isn't there, at the start menu, type Performance and select the Performance Information and Tools. Click Advanced Tools. There should be an item for diagnose Aero.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.