Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I use ip address to go to www.google.be for instance, it does work. How do I make the dns work in my Virtual Windows Xp machine?

Update:

Virtual Maching: ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : dell
Primary Dns Suffix  . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : telenet.be

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix  . : telenet.be
Description . . . . . . . . . . . : AMD PCNET Family PCI Ethernet Adapter
Physical Address. . . . . . . . . : 08-00-27-A0-BB-A1
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.162
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 195.130.131.130
                                   192.168.0.1

Host: ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : TLV-EDU-LIC
Primary Dns Suffix  . . . . . . . : TELEVIC.com
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : TELEVIC.com
                                   telenet.be

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix  . : telenet.be
Description . . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965AGN
Physical Address. . . . . . . . . : 00-1F-3B-98-94-51
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::adef:6e03:856c:eb9f%11(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.131(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 184557371
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-E7-EA-AE-00-21-70-84-0C-31
DNS Servers . . . . . . . . . . . : 195.130.131.130
                                   192.168.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled
share|improve this question

migrated from serverfault.com Aug 14 '11 at 5:52

This question came from our site for professional system and network administrators.

    
I don't see why this needs to be closed. Already searched an hour searching on google for this without any result. My host and vm can see each other. My host can browse to www.google.be but my vm not. –  Lieven Cardoen Aug 21 '10 at 16:06
    
Can you ping/access a numerical IP address (e.g. 8.8.8.8) from the VM? What is your virtual NIC setting (NAT,bridge,host-only,?)? Please post the output of running ipconfig /all in your VM's command line. –  Piskvor Aug 21 '10 at 16:12
    
He said he could goto the site if he used ip address, That would imply he can ping\access a numerical ip address. –  Joshua Enfield Aug 21 '10 at 16:28
    
Try setting your DNS servers to 8.8.8.8 (right click the connection goto properties or something like that> right click on ipv4 and goto properties again, and then put in your own DNS servers(8.8.8.8 in this case)) 8.8.8.8 is Google's free dns. –  Joshua Enfield Aug 21 '10 at 16:29
    
8.8.8.8 doens't work. Pinging a numerical IP address works. I have tried with all virtual NIC settings, none of them work. Now I use the bridge. I posted the output of running ipconfig /all on my vm and host. –  Lieven Cardoen Aug 21 '10 at 21:08

2 Answers 2

You probably have the Network setting in Virtualbox set to NAT. If you set it to Bridged, then this virtual machine will do DHCP like any other machine on your network and should therefore get the proper DNS configuration. This might not work if you are on an office network where the DHCP service is tightly controlled and they don't accept unknown MAC addresses on the network.

share|improve this answer

I use VMWare Fusion 3 in my iMAC - and IN MY XP PRO INSTANCE I simply point my XP DNS nameserver to my home router IP. My home router supplies all my DNS through "OpenDNS" - 208.67.222.222 and 208.67.220.220.

share|improve this answer
    
Doesn't work either. I'm really stuck with this. I have tried this in the past with Virtual PC without any problem. –  Lieven Cardoen Aug 22 '10 at 8:45
1  
To be honest, when I tried using VirtualBox, I found there was some issues getting my "guests" to properly hook into my "shared" ethernet interface either wired or wireless. I tried to coax the configs several times, then uninstalled it completely. Try to ping your DHCP Server/Gateway. If you cannot get a response, then that would explain everything. Maybe you can cajole your VBox to properly NAT. I was never successful. I don't have that much patience with wares that don't work right the first time.. Sorry. –  Rick Gillette Aug 22 '10 at 17:53
    
Me neither, so I'll probably uninstall the whole thing again and use another solution. –  Lieven Cardoen Aug 22 '10 at 18:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.