Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As a developer, I have a program running called AppFabric. AppFabric requires a UNC path to a shared folder to store its settings (for instance, \\machine\share pointing to c:\folder_to_share). Now, sometimes I'm in a place where I can't connect to a network. At those times, the UNC path \\machine\share doesn't appear to exist anymore.

So how would I access a UNC path pointing at a local share when I don't have a network connection? This is in Windows 7. Note that as soon as I connect to a network, the UNC path is usable again, and also note that this program will not allow drive letters but requires a UNC path (I know, boo!).

share|improve this question

3 Answers 3

up vote 2 down vote accepted

If the networking, or lack there of, is causing the issue you can always install the loopback adapter to force IP networking, even if its not there.

share|improve this answer
    
It was indeed the lack of network adapter. Thanks for suggesting the Microsoft Loopback Adapter; a couple of minutes of googling and following directions, and I had it installed. For others looking, here's the link I found and followed for Windows 7: social.technet.microsoft.com/Forums/en-US/w7itpronetworking/… –  Thorin Aug 15 '11 at 0:37

I think the issue is that you are not forming your UNC paths correctly (based on your post). It should be \\machine\share. You are missing a slash.

share|improve this answer
    
Hope you don't mind my edit! He was using double slash. If formatting gets messed up, try placing it in quotes. –  William Hilsum Aug 14 '11 at 23:46
    
Thanks for the edit, William, to clean up my formatting. I had entered double-slash but didn't check close enough what the output was in the post. –  Thorin Aug 15 '11 at 0:38

Firstly, a few other names to test are \\localhost and \\ip.address.of.machine.

If this doesn't work, I'm guessing that this is down to selecting Public Network as your zone/area in Network and Sharing Centre which disables File and Printer sharing.

With File and Printer sharing disabled, there is no way to emulate this (and I wouldn't recommend it for security reasons).

However, if you know what you are doing, you can either change the zone by clicking on it (1), or click on Change Advanced Sharing Settings (2) and manually enable it for your zone.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.