Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Ubuntu on my DELL's D Drive (Secondary Partition) and I lost the windows vista boot which was on my C Drive. Now when I boot my system directly loads Ubuntu, which seemed to me that GRUB was not installed. So I installed GRUB2

sudo apt-get install grub-pc

I checked the version to get:

$ grub-install -v
grub-install (GRUB) 1.99~rc1-13ubuntu3

Now how do I configure grub to list both Ubuntu (sda5) and windows vista (sda3)? Or that is not possible :(

The Catch:

My CD drive is broken so I cant use any Live CD

PS: I have a mem-stick with Ubuntu installed

share|improve this question
add comment

2 Answers

If you have a Windows installation CD, follow these steps:

  1. Insert the Windows installation disk (may be a USB drive).
  2. Restart the computer (making sure that the BIOS is configured to boot from that).
  3. Once started and loaded, choose the "Repair your computer" option.
  4. From the next set of options, select "Startup Repair". Once complete the computer will restart and the problem should be solved.
share|improve this answer
    
In the future, please don't cross-post on multiple Stack Exchange sites. Thanks. –  nhinkle Aug 16 '11 at 23:37
add comment

Try running this to see if Grub will add Windows to its menu:

update-grub

Make a new file, /etc/grub.d/11_windows, with this content:

#!/bin/sh -e
echo "found Windows Vista" >&2
cat << EOF
menuentry "Windows Vista" {
    set root=(hd0,3)
    chainloader +1
}
EOF

Then run

update-grub

again.

share|improve this answer
    
I dont think so, this is the out put which i get: Generating grub.cfg ... Found linux image: /boot/vmlinuz-2.6.38-10-generic Found initrd image: /boot/initrd.img-2.6.38-10-generic Found linux image: /boot/vmlinuz-2.6.38-8-generic Found initrd image: /boot/initrd.img-2.6.38-8-generic Found memtest86+ image: /boot/memtest86+.bin done –  LtColPHP Aug 15 '11 at 7:55
    
I've edited my answer with a new solution; please give that a go. –  Delan Azabani Aug 15 '11 at 8:18
    
nope , the output is the same as above ... no sign of window –  LtColPHP Aug 15 '11 at 8:38
    
Make sure that the 11_windows file you have made has the executable bit enabled, and try again. –  Delan Azabani Aug 15 '11 at 9:31
    
great... Generating grub.cfg ... Found linux image: /boot/vmlinuz-2.6.38-10-generic Found initrd image: /boot/initrd.img-2.6.38-10-generic Found linux image: /boot/vmlinuz-2.6.38-8-generic Found initrd image: /boot/initrd.img-2.6.38-8-generic found Windows Vista Found memtest86+ image: /boot/memtest86+.bin done ............. it worked...now what should i do? –  LtColPHP Aug 15 '11 at 16:43
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.