Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently on a computer running Windows 7 on a domain the Windows Update does not run by itself because "You receive updates: Managed by your system administrator". The error code is 8024402C

Detail: Open Windows Update, there you see a red message "Windows could not search for new updates", Code 8024402C. Below there is an interesting message: "Your receive updates: Managed by your system administrator".

At the bottom there is a link "Check online for updates from Microsoft Update". If I click it it will work but I want the windows update to work by itself not manually.

This system is not connected to the domain most of the time (laptop).

In Microsoft knowledge-base they say that this is caused by WSUS (Windows Server Update Services).

I want to have automatic updates from WU and WSUS in the same time. If this is not possible I would like to know how can I switch from WSUS to WU. I do have administrator account for local computer.

share|improve this question
    
The reason MS doesn't allow both is because that defeats the whole purpose of a WSUS server on a domain. The purpose of the WSUS server is so IT can test the patches and verify them before they are approved to go out to the users. If you defeat the WSUS server, or allow the computer to just download patches straight from Windows Update you are are more likely to get a patch that will break something on your computer. Then you will be crying to the IT department that your computer doesn't work right when you were the one who did it. If you are having this issue, please work with your IT departm –  user71307 Mar 11 '11 at 18:57

1 Answer 1

up vote 6 down vote accepted

In Windows 7/Vista right below the managed by system administrator message is a link you can click that allows you to search for updates from Windows Updates.

The settings are specified via the GPO wish is most likely implemented by your corporate IT department. The only way to overridden this is to change the GPO directly, however this will get overridden the next time you connect to the corporate network.

The easiest way would be to request to be removed from the Windows Update group. However if you want to override it manually this article will give you the registry keys to edit to change it. You can also do it through the Local Policy Editor by following these instructions.

share|improve this answer
6  
Thanks, I solved the issue my modifying: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU] "UseWUServer"=dword:00000000 If needed I could add this one to a startup script. Wonder why Microsoft didn't considered a value for using both (with fallback). –  sorin Aug 30 '09 at 11:14
    
The latter will apparently be available in the next WSUS. Not sure when thought. The ability to manual select however is a good start. –  Diago Aug 30 '09 at 11:31
    
Change the key in regedit like @sorin said, then restart the Windows Update service (via services.msc). I was getting another generic error (80070057) until I restarted the service. –  Luc Jul 14 at 23:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.