Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last night, I was trying to restore my iPhone, got it stuck in recovery mode, and in the process had to install known software(iReb, iRecovery, etc). The problem is, now my computer is seriously messed up. It does not identify any USB device and I get a "no Wireless adapter/hardware found", so I cannot access the internet. Luckily, I have a dual-boot ubuntu set up. I think that all the drivers are gone, but I cannot be sure. All i know for sure is that wireless (which was working perfectly before) says hardware is no available and USB ports don't seem to work for any device. I can still use, for example, Eclipse IDE and other things that don't require internet. If this was a virus, I saw no other manifestations of a bug in my computer. This has hindered my work.

share|improve this question
If you have an answer to it, post it and mark as "correct". Or if a user posted an answer that fixed it, mark theirs as correct. – Simon Sheehan Aug 16 '11 at 3:06

First, backup all of your data from Windows 7 onto either another partition, or an external source (hard drive, flash drive, whatever)

Second, try a repair install of Windows (instructions can be found here or here.)

share|improve this answer

I'd try sfc /scannow to try to restore the default drivers (and any other mucked up system files) - this SHOULD leave USB usable again, then reinstall the drivers for anything that needs additional drivers.

share|improve this answer
I'm sorry, but are these programs or command line prompts(i'm a newbie) – Kgrover Aug 16 '11 at 0:05
ok, got it. i will try this and let you know – Kgrover Aug 16 '11 at 0:06
command line prompt - editing answer with a link – Journeyman Geek Aug 16 '11 at 0:06
It says all files are fine no errors found. – Kgrover Aug 16 '11 at 1:30
that means the basic drivers, including USB.sys are there. check in device manager to see if there's any ! s or of devices are disabled. – Journeyman Geek Aug 16 '11 at 3:17
up vote 1 down vote accepted

I solved this problem by doing a system restore to four days ago. This got the USB and Wi-Fi working.

share|improve this answer
(I cannot accept this answer yet) – Kgrover Aug 16 '11 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .