Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I moved back in to my college apartment with some crappy ISP. Last spring, I had no problems, but now, my Macbook can connect to the network just fine when booted into Windows, but can't in OS X.

In Windows, it gets a 10.1.x.x IP, in OS X, just a 192.168.x.x address. The same goes for the default gateway- in Windows, 10.1.x.x, in OS X, 192.168.x.x. So it seems like OS X is not detecting network configuration correctly or something. Is there some way I can give it hints but still let the network assign me an IP address? Or any other ideas?

I've had to call the ISP's support multiple times in the past and it is always an excruciating experience so I'm hoping I can fix this myself.

share|improve this question

2 Answers 2

No. If OS X is getting a 169.x.x.x address, it's not working. 192.168.x.x means there's a DHCP router giving out IP addresses, or it's statically assigned.

So check Windows to see if it's statically assigned or DHCP. Then copy those settings to OS X.

share|improve this answer
    
They are both using DHCP. Default everything. –  Rob Lourens Aug 16 '11 at 2:35
    
It doesn't make sense that one network would give you 10.x.x.x or 192.168.x.x depending on your operating system. Have you checked your router? –  user3463 Aug 16 '11 at 3:58
    
I agree :P. My iPod Touch has never been able to connect to the network in the past, and the ISP basically told me to shove it. Same result whether connected to the wireless router or plugged into the wall. (I don't have a modem in my apartment, it's a shared connection across the building I guess) –  Rob Lourens Aug 16 '11 at 5:18
up vote 0 down vote accepted

After many hours, it started working. I changed nothing.

Weird problem- my friends' macbooks had the same issue as mine in OS X, my friends' windows PCs worked fine, and I had the problem described above. Whatever. I hate this ISP so bad.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.