Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a Ubuntu (11.04 Server Edition) virtual machine as my development environment. It doesn't have a desktop environment since I don't think its necessary and I want to keep it lightweight. I'm accessing it via SSH with PuTTY on Windows 7. I grew fond of Emacs 24 as an IDE but still want to use inside a terminal.

I successfully enabled the 256 color version of xterm to render Emacs 24 themes properly, however the terminal doesn't render comments in italics and classes/functions/methods underlined as it is declared on the theme code. I noticed that the bold font style works after enabling it in PuTTY.

I tried changing the Terminal-Type string in PuTTY to rxvt-unicode with no avail. I also tried other terminal emulators like SecureCRT and forks like PuTTYcyg and KiTTY since I noticed Putty doesn't display fonts in italics as a general font setting.

I also tried Vim and other systems with all this options and configurations and it didn't work.

Is there a way to achieve this? How?

share|improve this question
    
Can this be of help - unix.stackexchange.com/questions/17680/… - ? – Mirzhan Irkegulov Oct 26 '11 at 4:40

Just an FYI: Anything libvte based supports bold, italics, underline and strikethrough. No other terminal engine supports all four. Application support is virtually zero though because the functionality is only a few months old and it'll be many many years before the escape sequences are accepted and standardized.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .