Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How could I best resolve an issue with an RDP connection problem between two Windows 7 machines, is there any kind of log file or something similar?

  • RDP is enabled on the target computer
  • I can ping the target computer, and back from target to "source"
  • I have tried "Allow .. any version" and "Allow ..." modes
  • I have tested with Windows 7 "auto logon" and "auto logoff"
  • RDP works with another Windows 7 target computer (same laptop to other target)
  • I have tried with IP and DNS name settings
  • Both Windows 7 computers are in the same workgroup (home-network, no domain)
  • Several restarts of the "target" computer in between

I would need anything where I can get further details about the communication issue. The only thing I see is RDP's "Initiating remote connection" and then the failure alert.

Further network checking - due to your help - showed the network was "Public", changing it to "Home network" resolved the issue.

share|improve this question
up vote 4 down vote accepted

Try using tcping...exe`` to check that the RDP port, 3389, is open. Run this from the source computer to the RDP target. If it is not making a connection, then it may be that the Windows 7's firewall is blocking the connection. Temporarily disabling the firewall for a minute and then retrying RDP would confirm this. Make sure to turn it back on and include an exception for Remote Desktop.

On the target RDP system, run (as Administrator) netstat -a -b to ensure that the RDP service is running. svchost...exe`` should be listening on

share|improve this answer
It was not exactly the issue, but absolutely pointing in the right direction. My target was - for some reasons - connected as "Public network", changing to "Home network" resolved the issue! – Horst Walter Aug 16 '11 at 12:57
Public Network, by default, will block RDP connections. – surfasb Aug 16 '11 at 13:09
Yep, that I have realized :-( Actually it was not my intention to use "Public", it obviously happened 'cause I have changed by ADSL modem and did not pay the needed attention when reconnecting. It is good that no RDP connections are possible in an public environment. Anyway, thanks for clarifying it here. Because of the above answer I came across the root cause when checking the firewall, I was looking in the wrong corner. – Horst Walter Aug 16 '11 at 15:47

What edition of Windows 7 is running on the target computer? Only Ultimate and Business have the terminal server installed and enabled for RDP. Home premium, Basic, and Starter do not. You will not be able to RDP to the target computer if it is running one of the latter editions. Either upgrade, or try to use something like VNC, or attempt to add the functionality back in by patching your executables. My experiences with helping a friend try that last one when she found herself in this situation were not very successful.

share|improve this answer

You might use the Windows Logs or Application and Service Logs under Event Viewer for troubleshooting.

I'm not at my Windows 7 machine at the moment but you might try seeing if there is a Terminal Service or RDP Application trace log that can be enbabled. Open Event Viewer and then it will probably be under "Application and Service Logs", I think it shows as Terminal Services, but there might be one for Remote Desktop Services. I have used those for troubleshooting what WMI was doing and it is very useful. If you find one to enable, drill into and I think it shows a "Trace log" or something, you will then right-click it and should be an option to enable log or start log.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .