Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My wife has a Western Digital My Passport Essentials USB 3.0 HDD (P/N: WDBACY5000ABL - 00) which has started to behave quite flaky lately. Particularly, it's registering as unformatted despite currently having (to my knowledge, but not showing in the OS) 40+ GB stored on it.

I've tried using a forensic data recovery tool to pull data from the drive, but very few files were actually found and none seem to have been recovered intact. I'm wondering if there might be some sort of hardware failure involved here.

I know that there are tools to perform hardware tests on SATA/IDE drives, but I'm also aware that many USB drives are hard-wired to the USB controller in their enclosure. Are there any utilities that can do diagnostics on these sorts of drives? I've tried checking WD's website, and haven't found any - though it's always possible I just haven't looked in the right places yet.

share|improve this question
    
Are you using this drive on USB 3.0 ports or USB 2.0 ports? –  Shinrai Aug 16 '11 at 14:28
    
@Shinrai - USB 2.0 ports, using the 3.0 cable that came with the drive. Thanks. –  Iszi Aug 16 '11 at 14:29
    
Do you have something with USB 3.0 available that you can test with? While in theory they should be compatible, in practice there might be something faulty with the implementation on this drive. –  Shinrai Aug 16 '11 at 14:31
    
@Shinrai - Thanks for the info. Unfortunately, I've got nothing that new in terms of laptops, PCs, or adapters. –  Iszi Aug 16 '11 at 15:01

3 Answers 3

If you're fairly certain it's a hardware issue, then you can use the Data Lifeguard Diagnostic tool from Western Digital. A quick-test does a small test of the SMART data, while an extended test will check the disk surface for corrupted sectors. If you think there's a problem but the disk passes the quick test, try the extended one (it will not complete if there is a problem).

If you want to attempt to repair/recover the data, try TestDisk (free, cross-platform, and open source) - it works on almost all drives on a system, regardless of wether they are internal or external. If the drive doesn't show up in Windows explorer, the partition table might be corrupted. You can use TestDisk to repair/overwrite them (it can find corrupted or missing partitions and rewrite the partition table).

Alternatively, you can also use TestDisk to simply recover the files (if you just want to format and start from scratch). TestDisk can also overwrite/recover the MBR or boot sector if that's corrupted as well. I've had success using it to copy files off of corrupted partitons/drives, since Windows Explorer would often hang when copying from bad sectors.

share|improve this answer
    
Looks like a great utility, and thanks for the pointer. However, I'm looking to do diagnostics on the drive hardware itself and I don't see where TestDisk offers that. –  Iszi Aug 16 '11 at 15:31
    
Have you tried the Data Lifeguard Diagnostic tool from WD? Perform a quick test, and if that passes, then move onto an extended drive test. Just note that you can't actually recover anything with that tool (that's what you have to use TestDisk for). –  Breakthrough Aug 16 '11 at 15:32
    
I thought that tool was just for direct-connected SATA/IDE drives? Also, I don't see it available for my drive (support.wdc.com/product/…) - are you sure it's compatible? –  Iszi Aug 16 '11 at 15:53
    
AFAIK, it will work with most WD hard drives (it doesn't care about the type of enclosure). Give it a shot, and let me know if it works. Again though, you might have some luck if you use chkdsk to try to recover the corrupted sectors, and/or use TestDisk to ovewrite the partition tables. –  Breakthrough Aug 16 '11 at 16:01
    
I'll give the Data Lifeguard tool a shot, I guess. As far as the others, I'm trying to do as much testing and recovery as possible without actually writing to the drive since I know that's where things usually start to go way south in terms of recoverability. Please do add the diagnostic tool to your answer, so I can accept it if things go well. –  Iszi Aug 16 '11 at 16:13

I've used testdisk to recover data from corrupted usb drives before under both windows and linux but that does rely on the drive being successfully detected by the OS even if it's not showing as formatted. No guarantees but it is worth a try.

share|improve this answer

I would remove the drive from the enclosure, if the usb chip in the enclosure is defective, then no tool will help, you must remove the drive from the faulty enclosure, use another hard drive to usb adapter to attempt recovery of your data.

share|improve this answer
    
This presumes the drive isn't hard-wired to the USB controller - not the answer I'm looking for (see my OP). –  Iszi Aug 16 '11 at 15:28
    
I have never ween one that was "hard-wired", but I suppose they could start that nonsense at any time, most of the time when I see this type of partition loss it is the usb controller gone bad, not the hard drive inside. –  Moab Aug 16 '11 at 18:48
    
I haven't taken apart that many to know, but I remember doing a search online and finding reports of some external drives where the HDD was inseparable from its USB controller. Either way, I'd rather not crack the case open on this one if I can avoid it anyway. –  Iszi Aug 16 '11 at 19:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.