Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently made the switch from OS X's Terminal app to iTerm2. There is a small issue which is annoying me. After every command a %-sign is printed out in the terminal.

I also have a Debian 6 VM, which I SSH to. On that machine I get a # instead of the %-sign.

Is there any way to disable this?

share|improve this question
    
Why would you want to disable the prompt? And are you saying you had no prompt visible in Terminal.app? There should be no difference between the prompt in the two apps, since that is controlled in your shell's rc files. –  iconoclast Sep 11 '13 at 2:56

2 Answers 2

that's the prompt, provided by whichever shell you're running. You can see which shell you're currently running with

echo $SHELL

then you can do some reading on the 'net about that particular shell and how to customize your environment. For example, if you're using bash, http://osxdaily.com/2006/12/11/how-to-customize-your-terminal-prompt/ or http://www.macworld.com/article/146550/2010/02/rootprompt.html would be good places to start.

share|improve this answer
up vote 1 down vote accepted

I fixed this issue by setting Report Terminal Type to rxvt in the settings.

share|improve this answer
    
Welcome to Super User! Please don't forget to click the accept mark in a few days to mark this question solved, this will increase your accept rate and will ensure your future questions get answered too. –  Tom Wijsman Aug 19 '11 at 13:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.