Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got broadband. When I connect to my to my laptop, it works fine. But my desktop is not able to connect to internet. When I see Network connection details, it shows 100.0Mbps but no browser shows any website.

My desktop uses, Windows 7 and F-secure.

share|improve this question
What type of router do you have? Are these computers wired or wireless? Are they static or DHCP? What is their IP address on the LAN? Can the desktop ping the gateway? Can the desktop ping your ISPs DNS servers? Can your desktop ping – MaQleod Aug 17 '11 at 17:33

Basically put, your LAN card probably has a gateway set and there are conflicting routes on both connections. Your computer is prioritising other network connections over the mobile stick.

Typically, modems get a lower metric, but, if it is not being detected as a modem and is just another network card, it is not getting the priority.

You have two choices, the first is to change the device metrics (and if you want to know how to do this, let me know and I will write a guide), but, without getting complicated and changing the device metrics, I would recommend you try to disable or disconnect your other interfaces first.

share|improve this answer

Set your desktop LAN for dynamic IP-address asignment and restart it.

To check settings you can open a command prompt and type ipconfig the "default Gateway" should be your broadband router, you should be able to see it's settings by visiting that IP-address using a web browser.

I'm assuming you have a WiFi router with built in fast-ethernet and your desktop is connected by a cat5 patch cable. If you have a USB DSL modem, the solution will be different.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .