Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having issues with my ASUS P5N-E SLI USB ports. Sometimes they won't recognize any USB device in them and other times they will perform flawlessly. I've even had to move my wireless keyboard/mouse combo to the PS2 ports to ensure functionality.

I'm running Vista Business 32-bit SP2 and have updated to the most recent BIOS (1403). Does anyone have any ideas how to get them functioning properly?

Thanks! -JFV

share|improve this question
    
Have you seen if there are updated chipset drivers for the motherboard? –  MDMarra Oct 26 '09 at 22:10
    
I have updated the chipset drivers from the ASUS website, but I haven't seen a change in functionality... I'm not sure where to go from here... Sometimes I still need to restart the computer for them to be seen properly. Mostly this happens in the front USB ports... Maybe there's an issue with that connector on the MB? –  JFV Oct 27 '09 at 3:03

2 Answers 2

Just for the record I have a P5B-E that was pretty much doing the same thing, except across all USB ports including the front ones. Managed to make it better for a while by forcing USB 1.1 (disabling the USB 2.0 host controller in device manager). Eventually, even that started getting flakey.

Now they don't work at all, not even with live cd's or in the BIOS. They still provide the 5v rail though. My only solution was to buy a PCI USB card.

Not saying it's definitely hardware, but it seems awfully familiar from my standpoint.

My recommendation would be to download a linux live cd (ubuntu has pretty good driver support) and see if it still happens - linux uses completely separate drivers to windows. If it does and it's still under warranty I'd definitely organise an RMA.

share|improve this answer

Maybe check USB power settings?

Start -> Run -> powercfg.cpl -> Change plan settings (of selected plan) -> Change advanced power settings

USB settings -> USB selective suspend setting -> disabled

share|improve this answer
    
@hyperslug: Thanks for the suggestion, but I already have it set to disabled. –  JFV Aug 30 '09 at 17:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.