Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have one Windows 7 desktop that seems to be stuck on an APIPA address. It can see the other computers in the workgroup, but seemingly only communicate via IPv6 (see below), and can't access outside the LAN. The problem began today after completing a Windows update. Troubleshooting so far has already included:

-Ipconfig release/renew
-Uninstalling/reinstalling the NIC driver
-Checking device manager for "hidden" NIC drivers (none)
-Flushing DNS and ARP
-Resetting winsock and ipv4 using netsh
-Manually assigning an IP address on my subnet
-Doing a system restore to before the Windows update
-Restarting DHCP client service
-Disabling Windows Firewall
-Unloading TrendMicro
-Malware Bytes scan

I tried unplugging the ethernet cable from that PC and putting it in a laptop and it connected fine, got a proper IP, and connected to the internet (yes, I disabled WiFi on the laptop before testing).

Currently, when I try to ping another legitimate address on the network or the router (192.168.0.1), I'm getting:

PING: transmit failed. General failure.

Interestingly, when I ping the NetBIOS name of another host, it works, but it is running the ping over IPv6.

I then tried to ping -4 [host name], which returned:

Ping request could not find host [host name]. 

Also, an ipconfig/release returns this:

An error occurred while releasing interface Local Area Connection : An address has not yet been associated with the network endpoint.

An error occurred while releasing interface Loopback Pseudo-Interface : The system cannot find the file specified. 

I am stumped! I hope somebody has a suggestion short of a fresh Windows install or replacing the NIC.

share|improve this question

migrated from serverfault.com Aug 17 '11 at 21:51

This question came from our site for system and network administrators.

    
What about your event logs? Is your hostfile configured correctly? –  Holocryptic Aug 16 '11 at 2:54
    
Things have been tainted now with the system restore. Always uninstall updates from the Programs and Features tool. System restore is a last ditch effort to get a system up so you can remove files and then drop a grenade. –  Wesley Aug 16 '11 at 3:25
    
@Holocryptic: What should I look for in the event logs? I'm fairly certain the hostfile has no changes from default, but I will confirm tomorrow. Could a hostfile misconfiguration even cause APIPA? –  Joe M. Aug 16 '11 at 6:51
    
@WesleyDavid: I'll keep that in mind.. I was already kind of in "last ditch" state of mind as I had tried most of the other things on my list already at that point. Any suggestions given that I've already done it on this PC? –  Joe M. Aug 16 '11 at 6:52
    
After some quick googling around, I saw a mention of the localhost setting in the hostfiles getting hosed as a possible cause. In the eventlogs you should look for any errors that show up when you try to ping or do any NIC config –  Holocryptic Aug 16 '11 at 10:18

2 Answers 2

up vote 3 down vote accepted

Well I left MalwareBytes "Full Scan" running over night and when I returned in the morning there was one infected file "Backdoor.bot" that the "Quick Scan" didn't pick up. As soon as I cleaned it the problem resolved itself.

share|improve this answer

In order to resolve APIPA first run cmd prompt in admin mode and do the following:
Note: if you dont run the cmd in admin mode, it wont work.

netsh winsock reset all 

netsh int ip reset all

After this, you'll have to restart the computer. Do not attempt to open a browser or whatsoever.

Once the computer has restarted it should work

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.