Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem updating a Windows 7 machine with KB2518870. This update is for .NET Framework 4.0. It fails! What should I do?

  1. Ignore?
  2. Uninstall .NET Framework and then try the update?
  3. Use a better plan?
share|improve this question
    
Try with a restart. Have you updated earlier and not restart the PC? –  avirk Aug 18 '11 at 10:19
    
Thank you for your help. I am at a relative's house trying gingerly to sort out their problem. –  Guy Thomas Aug 19 '11 at 9:20
add comment

2 Answers

up vote 1 down vote accepted

Take good backups, including maybe a hard disk image, before trying my advice below.

First, try to download the patch from Security Update for Microsoft .NET Framework 4 and apply it this way.

If this doesn't work, you could try to repair .NET 4.0 in Control Panel / Programs and Features: Right-click on it and choose the Repair option.

If this still doesn't work, you can try uninstalling .NET 4.0.

If uninstallation doesn't work, use the .NET Framework Cleanup Tool. Read the linked article very carefully before using this tool.

share|improve this answer
    
Will try the cleanup tool later today –  Guy Thomas Aug 19 '11 at 9:20
    
Thank you for the cleanup tool, it removed .NET when Uninstall did not. –  Guy Thomas Aug 20 '11 at 7:32
add comment

I would highly recommend you do not do a), b) is an option, but as for c)...

The most common problem for .NET updates to fail is lack of disk space, but it could be anything.

However, can you look in the Event Viewer and see if anything comes up? .NET is very good at logging/telling you what is wrong.

If you do not need to look back on the log, I recommend clearing it, applying the update again and checking for any events.

share|improve this answer
    
Tried the logs, seem comprehensive but difficult to id problem. Appreciate your advice on a). –  Guy Thomas Aug 19 '11 at 9:21
    
@Guy Thomas - can you post a screenshot and I will try to help further. –  William Hilsum Aug 19 '11 at 9:22
    
Dear William thanks for the offer of extra help. The cleanup tool turned out to be the solution hence I ticked the above answer. –  Guy Thomas Aug 20 '11 at 7:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.