Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to get Mercurial installed on my 32bit 2003 server and i have been running into some issues. i have followed these instructions (which is the most current that i can find) with the exception i used the following versions that differ.

  • python 2.6.6
  • mercurial 1.9.1
    • mercurial 1.9 (no change/ same error)
    • mercurial 1.8.1 (no change/ same error)

After the install everything appears to be ok but then i get this error in eventvwr when i hit the site.

Failed to import callback module 'hgwebdir_wsgi'

I'm not sure where to start with this one, i have tried this but it didnt seem to make any change. I even tried this twice once as an over install/upgrade and once as a clean install.

share|improve this question

migrated from stackoverflow.com Aug 18 '11 at 14:23

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I recently did the same as you on Windows Server 2008 with the same result when I used Mercurial 1.9.1. However, switching to an older version of Mercurial worked for me (I'm not 100% on the version number but I think it was 1.8.1)

Did you download the 1.8.1 version of hgwebdir_wsgi.py and regenerate the dll when you installed the older version of Mercurial?

Other possible issues: Did you remember to enable 32 bit extensions in IIS? Is python in your path? Can you execute it from a cmd prompt from any folder?

Edit: I followed these instructions and they are the ones that didn't work for 1.9 and did work for 1.8.1. Comparing them to the instructions that you followed I can see one step which is different: it says to download the source for mercurial and to compile it (your reference page refers to using the source installation but not to compiling it)

share|improve this answer
    
I did download and try the 3 versions above, 1.9.1, 1.9, and 1.8.1 each time i would regen the dll with the new version of hgwebdir_wsgi.py. At this time i have HG running and but not with the asapi module. –  YetAnotherDeveloper Aug 21 '11 at 16:38
    
I've added a reference to the page that I followed. It does have some differences. –  Steve Kaye Aug 22 '11 at 6:54
    
thanks, i will check this out when the next version comes out. i'm tired of messing with it for now. when i do get this running i will update this post. –  YetAnotherDeveloper Sep 4 '11 at 4:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.