Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having trouble understanding what is going on with my work PC. Whenever I boot it, it runs fine for a while, then starts to randomly show disk errors. The displayed error often contains the message "not enough storage is available to process this command", although depending on the application that fails it can be different. This has happened for weeks now and is getting worse.

This is what troubles me:

  • It never seems to impact critical parts of the system (no BSOD, no freeze).
  • Only some applications seem impacted, refusing to function correctly after a while: Outlook 2010 cannot download RSS feeds anymore, Firefox 6 or IE9 cannot download anything bigger than 3MB without failing, Windows Update fails, all msi installers fail, Visual Studio 2010 starts failing in weird manners...
  • It only happens after a while using it (typically 3 hours, but it seems that installing a program or compiling several times makes it shorter)
  • Rebooting solves it (temporarily).

The system:

  • The OS is Windows 7 Pro Spanish SP1, 32 bits
  • The system is an HP Compaq 6000 Pro with 4 GB memory (only 3.4GB usable since the system is 32bit), one 500GB hard drive.
  • Installed applications include: Visual Studio 2010, SQL Server 2008 R2, VMWare Workstation 7, Microsoft Security Essentials, Office 2010. Shutting down all related services and processes doesn't seem to change anything.

The diagnostics I've run so far:

  • Hard drive : 465GB, 165GB free
  • Process Explorer : physical and virtual memory seem ok (pagefile is 5.3GB, physical memory usage 70%, system commit 39%)
  • Windows Memory diagnostic tool: OK
  • CHKDSK returned:
 488282111 KB total disk space.
 281668248 KB in 265779 files.
    150188 KB in 62949 indexes.
         0 KB in bad sectors.
    571755 KB in use by the system.
The log file has occupied 65536 kilobytes.
 205891920 KB available on disk.

For non-spanish speakers, that means all ok.

  • SMART diagnostic tools (DiskCheckup) report all values normal.
  • temperatures are in the normal range (HWinfo).
  • The event viewer doesn't seem to contain any significant message.
  • ran CCleaner 3, without any noticeable effect.

I was thinking about some file number limit (between Visual Studio projects and other applications, there are around 300.000 files on the hard drive), but I couldn't find any. It's possible there is something related with the use of the temporary folders (it's the only explanation I have for why applications fail but Windows doesn't), but I cannot confirm that.

Only thing I cannot find out is if chkdsk reporting 65MB for the log is normal. It seems since Vista it always reports this.

Any other cleaning/diagnostic tool you might know of?

Edit: I ran several other tools since I first published the question:

  • Seagate SeaTools (the HD manufacturer's analysis tool): complete test run OK.
  • Intel Rapid 10.1 (the HD controller manufacturer's troubleshooting tool): the HD's ok.
  • Microsoft Desktop Heap Monitor:

Desktop Heap Information Monitor Tool (Version 8.1.2925.0) Copyright

(c) Microsoft Corporation. All rights reserved.

Session ID: 1 Total Desktop: ( 46464 KB - 11 desktops)

WinStation\Desktop Heap Size(KB) Used Rate(%)

WinSta0\Winlogon (s1) 128 3.6
WinSta0\Disconnect (s1) 64 3.8
WinSta0\Default (s1) 20480 3.0
msswindowstation\mssrestricteddesk (s0) 1024 0.2
__X78B95_89_IW__A8D9S1_42_ID (s0) 1024 0.2
Service-0x0-3e5$\Default (s0) 1024 0.6
Service-0x0-3e4$\Default (s0) 1024 0.3
Service-0x0-3e7$\Default (s0) 1024 2.1
WinSta0\Winlogon (s0) 128 1.9
WinSta0\Disconnect (s0) 64 3.8

WinSta0\Default (s0) 20480 0.0

All ok, desktop heap usage < 5%

Edit 2: I tried totally resetting my account by creating a new one, logging under this new one and delete the first one (local rights and files), then logging back with this deleted account (it is a domain account). No luck.

Also, I found out often the error is "not enough storage is available to process this command". Searching on the internet, I found an old troubleshooting tip (setting a registry key to raise the IRP stack limit, whatever it is) which did not change anything.

share|improve this question
    
Can you run chkdsk with the /R flag to check for bad sectors? Alternatively, download your HDD manufacturer's diagnostic tools and run an extended surface test of the drive. –  Breakthrough Aug 18 '11 at 15:55
    
It kinda sounds like a "running out of heap" scenario, thought I can't guess what sort of heap (or other limited resource) or where. –  Daniel R Hicks Aug 18 '11 at 16:09
    
Have you emptied your trashcan recently? –  Daniel R Hicks Aug 18 '11 at 16:09
    
Have you done an offline scan for malware?...connect.microsoft.com/systemsweeper –  Moab Aug 18 '11 at 17:19
    
@ Breakthrough: I did the chkdsk (on reboot) and had the same results (no bad sector). Didn't do the HDD diagnostic tool yet. –  GFK Aug 19 '11 at 6:58

3 Answers 3

To begin with, SMART can lie.

Next, I have only seen this a few times and it is a really nightmare to fully diagnose.

It could be rogue software on your machine (or a bad/slow antivirus?), but, it is most likely hardware related.

Firstly, Are all machines the same specifications and build (or similar enough), and does anyone else have this issue?

If they have same machine and issues, it may and most likely be software.

If they don't, there are a few stages I would recommend... Feel free to skip over any if you have tried.

  1. Attempt to reload your Operating System (If it works, it was bad software)
  2. Replace the hard drive (If it works, it was a bad hard drive)

If you still have problems, this means that the most likely cause is a bad I/O or similar chip on your motherboard. Whilst the safest case is to get a new motherboard, it may be possible to get around the issues by purchasing a RAID adapter.

share|improve this answer
    
The company has a lot of computers with the same configuration, but mine has a different software configuration (a lot of things are installed actually, but it is all standard up-to-date work-related software). Reinstalling the OS seems the next step if I cannot find the solution, but I wanted to try every other possibility before, because reinstalling is going to be complicated (because of company bureaucracy). –  GFK Aug 19 '11 at 12:32

Make sure your TEMP folder exists. At a command prompt, type set and press Enter. You'll see all your environment variables. Among them you should see TEMP= and a folder. Make sure that folder exists and that it can be written to.

share|improve this answer
    
The folder exists (in C:\users\%USER%\AppData\Local\Temp) and is fully readable and writable by said user and Admin group. –  GFK Aug 22 '11 at 8:14
up vote 0 down vote accepted

Answering my own question: I don't have access to this computer anymore, but all problems were solved installing Windows 64 bits. After a few more queries on Google, without being able to troubleshoot (since I wasn't going to reinstall 32 bit Win just to confirm), I am pretty convinced that my problem was not the hard drive, but the memory...

The problem was that when the applications were logging an exception when failing, it generally was: Espacio de almacenamiento insuficiente para procesar este comando.

To me, this means Not enough storage space to process this command, but in fact it is actually the es-ES translation of the Windows error message Insufficient memory was available to complete the operation. In my opinion, this is a very misleading translation (considering the Spanish word memoria means exactly memory, they could have used it), but I am neither an English neither a Spanish native speaker, so I'll leave Microsoft the benefit of the doubt. It did lead me to a misunderstanding of the issue, though.

I think the issue was that Windows could not allocate sufficient pages to applications anymore, and/or memory pages allocated to applications memory were already too fragmented for the applications to actually use them.

In any case, I think this was just due to the fact that .net development is just too much for 32bit Windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.