Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try setting up Google Talk in Pidgin. I get the message:

Unable to Connect

EDIT:

(I have it working in Digsby fine)

Here is my setup:

enter image description here Advanced Tab

share|improve this question
1  
I checked my configuration - it looks the same, but in the connect server box it's just blank, which appears to be the default setting for Google Talk. Perhaps try taking that out and see if it works? – nhinkle Aug 18 '11 at 18:20
    
Having the same problem. Did you ever find the answer? – Alison R. Feb 9 '12 at 20:39
    
How do you get it to work if you have a Google account but don't have a Gmail account? – Chloe Sep 22 '14 at 17:18
    
i follow your guide religously but i get Not Authorized. Help. – publicENEMY Jan 29 '15 at 15:54

13 Answers 13

I used:

in the Basic Tab:

Protocol: XMPP
Username: myusername (without @mydomain.com)
Domain: mydomain.com
Resource: (left this blank as default)
Password: mypassword
Checked Remember password

in the Advanced Tab:

Connection security: Require encryption
Connect port: 5222 (default)
Connect server: talk.google.com
share|improve this answer
1  
Just to surface Nathan Adams' comment - if you're using a custom Google Apps domain, make sure you fill in the Connect server; the connection dropdown won't do it. – Jarrod Dixon Mar 26 '15 at 22:57

Google created the new Google Hangout, that replaces also Google Talk, and seems that XMPP support has been removed.

But there's a partial solution: enable access to Gmail from "less secure apps" and Pidgin will connect to it.

share|improve this answer
1  
This fixed the Not Authorized error im getting. Why nobody rated this up is beyond me. Thanks. – publicENEMY Jan 29 '15 at 15:56
    
Google's strategy of calling everybody else "less secure" for no reason other than promoting their own privative software. – Mario Feb 9 '15 at 20:23

I had to use Pidgin version 2.10.9, with the following settings:

Protocol: XMPP
Username: <Gmail user name> (without @gmail.com)
Domain: gmail.com
Resource: <blank>
Password: <app-specific password>
Remember password: Checked

In the Advanced Tab:

Connection security: Use Old-style SSL
Connect port: 443
Connect server: talk.google.com
File transfer proxies: proxy.eu.jabber.org (the default)

I'm not sure why I needed a different port than the other answers. Because I use two-factor authentification, or am behind a corporate firewall?

share|improve this answer

Pidgin works fine, when we enable the setting of less secure apps in your google account

https://www.google.com/settings/security/lesssecureapps

it worked fine for me after that :-)

share|improve this answer
    
Thank you Shyam - this works for me now . – Abed Yaseen Jun 10 '15 at 21:17

Pidgin comes preconfigured with an option in the drop-down menu called "Google Talk", which has all the settings already done. Type in your username/password and you should be able to connect.

share|improve this answer
1  
I tried that and it didn't help. It also changed back to XMPP. – JoelFan Aug 18 '11 at 19:02
    
Are you behind a network proxy? If so, please fill in those details and try the "google talk" protocol method again. – Sudipta Chatterjee Aug 18 '11 at 19:13
2  
If I remember correctly - if you select google talk in the drop down it won't allow you to use an account you have setup for your own domain because it changes to XMPP. I believe for that you have to manually configure it per yuvilo's instructions. – Nathan Adams Nov 26 '12 at 16:11

Gtalk is not working now, so I'm using pidgin now, and it's working great

Setting I've used:

in the Basic Tab:

Protocol: XMPP
Username: yourUsername (without @mydomain.com)
Domain: mydomain.com
Resource: (left this blank as default)
Password: yourPassword
Checked Remember password

in the Advanced Tab:

Connection security: Use Old-style SSL
Connect port: 5223 (there would be 5222 change it)
Connect server: talk.google.com
share|improve this answer
  1. Create an app-specific password for pidgin
  2. Add a pidgin account

    • Protocol: XMPP
    • Username: (your google username)
    • Domain: gmail.com
    • Password: (your app-specific password)
  3. That's it! There is no step 3!

share|improve this answer

You want to include your full domain in the username field, for example john.doe@gmail.com (which is needed for Google Apps accounts). You can leave the "domain" field blank.

enter image description here

share|improve this answer
    
When I try that, I get: Invalid XMPP ID – JoelFan Aug 18 '11 at 19:01
    
Pidgin requires you to type them apart; so, typing them together won't work. – Tom Wijsman Aug 19 '11 at 12:48

Just leave the File transfer proxies as blank in the Advanced tab.

share|improve this answer
    
Source? That doesn't seem right – Canadian Luke Aug 10 '13 at 16:18

I tried every method, same issue. The below settings fixed it:

Basic Tab: Protocol: XMPP Username: username (without the @gmail.com) Resource: Empty Password: Yourpassword

Advanced Tab: Connection security: Use encryption if available Connect server: talk.google.com File transfer proxies: empty (delete whats here)

Save, click enable check box.

share|improve this answer

You need to set app-specific password for Pidgin. Just follow the instructions at this link.

share|improve this answer
1  
Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Sep 26 '15 at 11:25

for me this helped:

Connection security: Use encryption if available.
Connect port: 5222
Connect server: talk.google.com
Also in Resource I entered "Home"
share|improve this answer

This is a step-by-step guide on
How to compile and install Pidgin and make it work with Google Talk (~ Hangouts) on Linux:

The differences between Hangouts and Google Talk you will find on this page:
https://support.google.com/a/answer/4564211

1. Enable 2-Step Verification on this page:
https://accounts.google.com/SmsAuthConfig

2-Step Verification

2. Generate a new App password for Pidgin on this page, select Other and name it however:
https://security.google.com/settings/security/apppasswords

App password

3. Install the latest version of Pidgin for your system from this page:
https://pidgin.im/download/ or from repository of your Linux distribution or compile it from source (or for Max OS X they recommend using http://adium.im/)

4. To avoid security bugs, you should often check if your Linux distribution repository contains the latest version available, which you may check on this page https://pidgin.im/news/security/

5. If you choose to compile, you simply install the dependencies, download and compile the code, and install Pidgin as follows:

$ sudo apt-get build-dep pidgin
$ sudo apt-get source pidgin
$ tar xjvf pidgin-2.x.y.tar.bz2
$ cd pidgin-2.x.y
$ ./configure && make && sudo make install

Alternately, e.g. on Debian, where you (by default) have to su instead of sudo (haven't tested myself, correct me if I'm wrong):

$ su -
# apt-get build-dep pidgin
# apt-get source pidgin
# exit
$ tar xjvf pidgin-2.x.y.tar.bz2
$ cd pidgin-2.x.y
$ ./configure && make
$ su -
# make install

If it fails for some reason, please refer to this page:
https://developer.pidgin.im/wiki/Installing%20Pidgin#WhycantIcompilePidgin

6. Right-click the system-tray icon of Pidgin and choose Accounts.

7. Add or modify your Google Talk account to have Username without @gmail.com or your own domain.

8. If you have your own domain for Google account, fill in the Domain field, otherwise there should be gmail.com present by default (without @).

9. The Resource is an XMPP specific thing that allows one to use several clients for the same account. Under normal circumstances leave blank.

10. Fill in the Password generated in step two.

11. Optional, but convenient, if on a secure computer, is ticking Remember password.

12. Local alias leave blank.

13. It should look like this:

Adding Google Talk account to Pidgin

14. On Advanced tab make sure you have Require encryption chosen and disabled plaintext.

15. Note, that after you save these settings, the protocol will automatically change to XMPP, which is currently available to third-party applications like Pidgin.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.